<!doctype html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="https://gmpg.org/xfn/11">
<title>February Update: Post CNY and FOSDEM Status Report | PINE64</title>

<meta property="og:image" content="https://www.pine64.org/wp-content/uploads/2020/02/Header.jpg" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="February Update: Post CNY and FOSDEM Status Report | PINE64" />
<meta property="og:url" content="https://www.pine64.org/2020/02/15/february-update-post-cny-and-fosdem-status-report/" />
<meta property="og:site_name" content="PINE64" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="February Update: Post CNY and FOSDEM Status Report | PINE64" />
<meta name="twitter:image" content="https://www.pine64.org/wp-content/uploads/2020/02/Header.jpg" />
<link rel="canonical" href="https://www.pine64.org/2020/02/15/february-update-post-cny-and-fosdem-status-report/" />
<script type="application/ld+json">{"@context":"https://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://www.pine64.org/","name":"PINE64"}},{"@type":"ListItem","position":2,"item":{"@id":"https://www.pine64.org/category/community/","name":"Community"}},{"@type":"ListItem","position":3,"item":{"@id":"https://www.pine64.org/2020/02/15/february-update-post-cny-and-fosdem-status-report/","name":"February Update: Post CNY and FOSDEM Status Report"}}]}</script>
<meta name="google-site-verification" content="-u-ZKaCKCdtW4_flGeI8rQ5A_fp8Qh0Wfb494XLgiMc" />

<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.pine64.org\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://c0.wp.com/c/5.3.2/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='ctf_styles-css' href='https://www.pine64.org/wp-content/plugins/custom-twitter-feeds/css/ctf-styles.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='gdpr-framework-cookieconsent-css-css' href='https://www.pine64.org/wp-content/plugins/gdpr-framework/assets/cookieconsent.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-css' href='https://fonts.googleapis.com/css?family=Lato%3A400%2C500%2C600%2C700' type='text/css' media='all' />
<link rel='stylesheet' id='news-portal-fonts-css' href='https://fonts.googleapis.com/css?family=Roboto+Condensed%3A300italic%2C400italic%2C700italic%2C400%2C300%2C700%7CRoboto%3A300%2C400%2C400i%2C500%2C700%7CTitillium+Web%3A400%2C600%2C700%2C300&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css' href='https://www.pine64.org/wp-content/plugins/elementor/assets/lib/font-awesome/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='lightslider-style-css' href='https://www.pine64.org/wp-content/themes/news-portal/assets/library/lightslider/css/lightslider.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='news-portal-style-css' href='https://www.pine64.org/wp-content/themes/news-portal/style.css' type='text/css' media='all' />
<style id='news-portal-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='news-portal-responsive-style-css' href='https://www.pine64.org/wp-content/themes/news-portal/assets/css/np-responsive.css' type='text/css' media='all' />
<link rel='stylesheet' id='elementor-icons-css' href='https://www.pine64.org/wp-content/plugins/elementor/assets/lib/eicons/css/elementor-icons.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='elementor-animations-css' href='https://www.pine64.org/wp-content/plugins/elementor/assets/lib/animations/animations.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='elementor-frontend-css' href='https://www.pine64.org/wp-content/plugins/elementor/assets/css/frontend.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-5-all-css' href='https://www.pine64.org/wp-content/plugins/elementor/assets/lib/font-awesome/css/all.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-4-shim-css' href='https://www.pine64.org/wp-content/plugins/elementor/assets/lib/font-awesome/css/v4-shims.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='elementor-global-css' href='https://www.pine64.org/wp-content/uploads/elementor/css/global.css' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-1-css' href='https://fonts.googleapis.com/css?family=Roboto%3A100%2C100italic%2C200%2C200italic%2C300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%2C900%2C900italic%7CRoboto+Slab%3A100%2C100italic%2C200%2C200italic%2C300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%2C900%2C900italic' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://c0.wp.com/p/jetpack/8.2/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript' src='https://www.pine64.org/wp-content/plugins/gdpr-framework/assets/cookieconsent.min.js'></script>
<script type='text/javascript' src='https://www.pine64.org/wp-content/plugins/elementor/assets/lib/font-awesome/js/v4-shims.min.js'></script>
<link rel="alternate" type="application/json+oembed" href="https://www.pine64.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.pine64.org%2F2020%2F02%2F15%2Ffebruary-update-post-cny-and-fosdem-status-report%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.pine64.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.pine64.org%2F2020%2F02%2F15%2Ffebruary-update-post-cny-and-fosdem-status-report%2F&#038;format=xml" />
<style id="mystickymenu" type="text/css">#mysticky-nav { width:100%; position: static; }#mysticky-nav.wrapfixed { position:fixed; left: 0px; margin-top:0px;  z-index: 99990; -webkit-transition: 0.3s; -moz-transition: 0.3s; -o-transition: 0.3s; transition: 0.3s; -ms-filter:"progid:DXImageTransform.Microsoft.Alpha(Opacity=90)"; filter: alpha(opacity=90); opacity:0.9; background-color: #2969b1;}#mysticky-nav .myfixed { margin:0 auto; float:none; border:0px; background:none; max-width:100%; }</style> <style type="text/css">
																											</style>
<script>
		//Autumn_check Weather effect Start
		 
		//Autumn_check Weather effect End
	</script>
<script>
		//winter_check Start
			//Winter snow Falling Start
			 
			//Winter Falling End
		//winter_check end
	</script>
<style>
		.we-flake{
			color:  !important;
		}
	</style>
<script>
		// spring_check Effect End
		 
	</script>
<script>
		// summer_check Effect Start
		  //summer_check Effect End
	</script>
<script>
		//halloween_check  Start
		 
	  //halloween_check End
	</script>
<script>
		//rainy_check Start
			 
	  //rainy_check end
	</script>
<script>
		//thanks_giving_check start
			 
		//thanks_giving_check end
	</script>
<script>
		//valentine_check start
			 
		//valentine_check End
	</script>
<script>
		//new_year_check start
			 
		//new_year_check end
	</script><link rel="apple-touch-icon" sizes="180x180" href="/wp-content/uploads/fbrfg/apple-touch-icon.png?v=lk94AAJxpr">
<link rel="icon" type="image/png" sizes="32x32" href="/wp-content/uploads/fbrfg/favicon-32x32.png?v=lk94AAJxpr">
<link rel="icon" type="image/png" sizes="16x16" href="/wp-content/uploads/fbrfg/favicon-16x16.png?v=lk94AAJxpr">
<link rel="manifest" href="/wp-content/uploads/fbrfg/site.webmanifest?v=lk94AAJxpr">
<link rel="mask-icon" href="/wp-content/uploads/fbrfg/safari-pinned-tab.svg?v=lk94AAJxpr" color="#5bbad5">
<link rel="shortcut icon" href="/wp-content/uploads/fbrfg/favicon.ico?v=lk94AAJxpr">
<meta name="msapplication-TileColor" content="#da532c">
<meta name="msapplication-config" content="/wp-content/uploads/fbrfg/browserconfig.xml?v=lk94AAJxpr">
<meta name="theme-color" content="#ffffff">
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<style type='text/css'>img#wpstats{display:none}</style><link rel="pingback" href="https://www.pine64.org/xmlrpc.php"><style type="text/css" id="custom-background-css">
body.custom-background { background-color: #d3d3d3; }
</style>
<style type="text/css" id="wp-custom-css">
				@media (max-width: 600px) {
	.np-ticker-wrapper {
			display: none;
	}
}

#post-2 + #comments {
    display: none;
}			</style>
</head>
<body class="post-template-default single single-post postid-1785 single-format-standard custom-background group-blog right-sidebar boxed_layout elementor-default elementor-kit-1801 elementor-page elementor-page-1785">
<div id="page" class="site">
<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
<div class="np-top-header-wrap"><div class="mt-container"> <div class="np-top-left-section-wrapper">
<div class="date-section">Monday, February 17, 2020</div>
<nav id="top-navigation" class="top-navigation" role="navigation">
<div class="menu-top-menu-container"><ul id="top-menu" class="menu"><li id="menu-item-822" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-822"><a href="https://store.pine64.org/">PINE Store</a></li>
<li id="menu-item-63" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-63"><a href="https://www.pine64.org/shipping/">Shipping Information</a></li>
<li id="menu-item-666" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-666"><a href="https://support.pine64.org/">Order Support</a></li>
<li id="menu-item-275" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-275"><a href="https://www.pine64.org/contact/">Sales Contact</a></li>
</ul></div> </nav>
</div>
<div class="np-top-right-section-wrapper">
<div class="mt-social-icons-wrapper"><span class="social-link"><a href="https://twitter.com/thepine64" target="_blank"><i class="fa fa-twitter"></i></a></span></div> </div>
</div></div><header id="masthead" class="site-header" role="banner"><div class="np-logo-section-wrapper"><div class="mt-container"> <div class="site-branding">
<p class="site-title"><a href="https://www.pine64.org/" rel="home">PINE64</a></p>
<p class="site-description">Open. Friendly. Community Driven.</p>
</div>
<div class="np-header-ads-area">
<section id="media_image-3" class="widget widget_media_image"><a href="https://pine64.org"><img width="3200" height="600" src="https://www.pine64.org/wp-content/uploads/2019/10/NewHeader.jpeg" class="image wp-image-1485  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" /></a></section> </div> 
</div></div> <div id="np-menu-wrap" class="np-header-menu-wrapper">
<div class="np-header-menu-block-wrap">
<div class="mt-container">
<a href="javascript:void(0)" class="menu-toggle hide"> <i class="fa fa-navicon"> </i> </a>
<nav id="site-navigation" class="main-navigation" role="navigation">
<div class="menu-main-menu-container"><ul id="primary-menu" class="menu"><li id="menu-item-53" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-53"><a href="https://www.pine64.org">Home</a></li>
<li id="menu-item-52" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-52"><a href="https://www.pine64.org/blog/">News Blog</a></li>
<li id="menu-item-582" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-582"><a>Forums and Chats</a>
<ul class="sub-menu">
<li id="menu-item-178" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-178"><a target="_blank" rel="noopener noreferrer" href="https://forum.pine64.org">Forum</a></li>
<li id="menu-item-804" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-804"><a href="https://www.pine64.org/web-irc/">IRC Chat</a></li>
<li id="menu-item-184" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-184"><a href="https://discordapp.com/invite/DgB7kzr">Discord Chat</a></li>
<li id="menu-item-1672" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1672"><a href="https://pine64.org">Matrix Groups</a>
<ul class="sub-menu">
<li id="menu-item-1676" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1676"><a href="https://matrix.to/#/!sbmInimykuNPjjIQMN:matrix.org?via=matrix.org&#038;via=t2bot.io&#038;via=privacytools.io">Pine64</a></li>
<li id="menu-item-1677" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1677"><a href="https://matrix.to/#/!cxuEuvbcTVbNqpHYIf:matrix.org?via=t2bot.io&#038;via=matrix.org&#038;via=chat.datenburg.org">Rock64</a></li>
<li id="menu-item-1673" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1673"><a href="https://matrix.to/#/!gPNBaTQpKsyjrTlLAl:matrix.org?via=matrix.org&#038;via=privacytools.io&#038;via=feneas.org">Pinebook</a></li>
<li id="menu-item-1674" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1674"><a href="https://matrix.to/#/!LZirCxnkkeBudrQzPj:matrix.org?via=matrix.org&#038;via=librem.one&#038;via=privacytools.io">PinePhone</a></li>
<li id="menu-item-1675" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1675"><a href="https://matrix.to/#/!MTPtVeaNjlLKdzMKWH:matrix.org?via=matrix.org&#038;via=privacytools.io&#038;via=feneas.org">PineTime</a></li>
</ul>
</li>
<li id="menu-item-1200" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1200"><a href="https://pine64.org">Telegram Groups</a>
<ul class="sub-menu">
<li id="menu-item-1202" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1202"><a href="https://t.me/mtrx_pine64">Pine64</a></li>
<li id="menu-item-1203" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1203"><a href="https://t.me/mtrx_rock64">Rock64</a></li>
<li id="menu-item-1204" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1204"><a href="https://t.me/mtx_pinebook">Pinebook</a></li>
<li id="menu-item-1205" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1205"><a href="https://t.me/pinephone">PinePhone</a></li>
<li id="menu-item-1400" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1400"><a href="https://t.me/pinetime">PineTime</a></li>
</ul>
</li>
<li id="menu-item-807" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-807"><a href="http://irc.pine64.uk">Chat Log</a></li>
<li id="menu-item-1278" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1278"><a href="https://www.reddit.com/r/PINE64official/">Official Subreddit</a></li>
</ul>
</li>
<li id="menu-item-584" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-584"><a>Devices</a>
<ul class="sub-menu">
<li id="menu-item-780" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-780"><a>Single Board Computers</a>
<ul class="sub-menu">
<li id="menu-item-68" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-68"><a href="https://www.pine64.org/devices/single-board-computers/pine-a64/">PINE A64 (+)</a></li>
<li id="menu-item-81" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-81"><a href="https://www.pine64.org/devices/single-board-computers/pine-a64-lts/">PINE A64-LTS</a></li>
<li id="menu-item-87" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87"><a href="https://www.pine64.org/devices/single-board-computers/rock64/">ROCK64</a></li>
<li id="menu-item-106" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-106"><a href="https://www.pine64.org/rockpro64/">ROCKPro64</a></li>
<li id="menu-item-91" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-91"><a href="https://www.pine64.org/pine-h64-ver-b/">PINE H64 ver. B</a></li>
</ul>
</li>
<li id="menu-item-779" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-779"><a>Laptops</a>
<ul class="sub-menu">
<li id="menu-item-95" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-95"><a href="https://www.pine64.org/pinebook/">PINEBOOK</a></li>
<li id="menu-item-111" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-111"><a href="https://www.pine64.org/pinebook-pro/">PINEBOOK Pro</a></li>
</ul>
</li>
<li id="menu-item-781" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-781"><a>Phones and Tablets</a>
<ul class="sub-menu">
<li id="menu-item-113" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-113"><a href="https://www.pine64.org/pinephone/">PINEPHONE</a></li>
<li id="menu-item-253" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-253"><a href="https://www.pine64.org/pinetab/">PINETAB</a></li>
</ul>
</li>
<li id="menu-item-1445" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1445"><a>Smartwatches</a>
<ul class="sub-menu">
<li id="menu-item-1459" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1459"><a href="https://www.pine64.org/pinetime/">PINETIME</a></li>
</ul>
</li>
<li id="menu-item-782" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-782"><a>Compute Modules</a>
<ul class="sub-menu">
<li id="menu-item-83" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-83"><a href="https://www.pine64.org/sopine/">SOPINE</a></li>
<li id="menu-item-177" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-177"><a href="https://www.pine64.org/baseboard/">BASEBOARD</a></li>
</ul>
</li>
<li id="menu-item-783" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-783"><a>Clusters</a>
<ul class="sub-menu">
<li id="menu-item-143" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-143"><a href="https://www.pine64.org/clusterboard/">CLUSTERBOARD</a></li>
</ul>
</li>
<li id="menu-item-784" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-784"><a>IP Cameras</a>
<ul class="sub-menu">
<li id="menu-item-140" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-140"><a href="https://www.pine64.org/cube/">CUBE</a></li>
</ul>
</li>
</ul>
</li>
<li id="menu-item-583" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-583"><a>Partner Projects</a>
<ul class="sub-menu">
<li id="menu-item-785" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-785"><a>A-M</a>
<ul class="sub-menu">
<li id="menu-item-691" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-691"><a href="https://aosc.io/projects/aosc-os">AOSC OS</a></li>
<li id="menu-item-681" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-681"><a href="https://www.armbian.com/">Armbian</a></li>
<li id="menu-item-695" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-695"><a href="http://batocera-linux.xorhub.com/">Batocera Linux</a></li>
<li id="menu-item-685" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-685"><a href="https://dietpi.com/">DietPi</a></li>
<li id="menu-item-684" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-684"><a href="https://hardenedbsd.org/">HardenedBSD</a></li>
<li id="menu-item-700" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-700"><a href="https://neon.kde.org/">KDE Neon</a></li>
<li id="menu-item-697" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-697"><a href="http://www.lakka.tv/">Lakka</a></li>
<li id="menu-item-917" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-917"><a href="https://en.wikipedia.org/wiki/LuneOS">LuneOS</a></li>
<li id="menu-item-690" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-690"><a href="https://libreelec.tv/">LibreELEC</a></li>
<li id="menu-item-702" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-702"><a href="https://maemo-leste.github.io/">Maemo Leste</a></li>
<li id="menu-item-680" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-680"><a href="https://manjaro.org/">Manjaro</a></li>
</ul>
</li>
<li id="menu-item-786" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-786"><a>N-Z</a>
<ul class="sub-menu">
<li id="menu-item-689" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-689"><a href="https://nemslinux.com/">NEMS Linux</a></li>
<li id="menu-item-682" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-682"><a href="https://www.netbsd.org/">NetBSD</a></li>
<li id="menu-item-698" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-698"><a href="https://ownyourbits.com/nextcloudpi/">NextCloudPi</a></li>
<li id="menu-item-683" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-683"><a href="https://www.openbsd.org/">OpenBSD</a></li>
<li id="menu-item-692" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-692"><a href="https://www.openhab.org/">OpenHAB</a></li>
<li id="menu-item-699" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-699"><a href="https://www.openmediavault.org/">Open Media Vault</a></li>
<li id="menu-item-701" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-701"><a href="https://www.plasma-mobile.org/">Plasma Mobile</a></li>
<li id="menu-item-687" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-687"><a href="https://postmarketos.org/">PostmarketOS</a></li>
<li id="menu-item-686" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-686"><a href="https://q4os.org/">Q4OS</a></li>
<li id="menu-item-693" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-693"><a href="https://www.recalbox.com/">Recalbox</a></li>
<li id="menu-item-694" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-694"><a href="https://odroidarena.com/">Retro Arena</a></li>
<li id="menu-item-703" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-703"><a href="https://sailfishos.org/">SailfishOS</a></li>
<li id="menu-item-688" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-688"><a href="https://ubports.com/">UBPorts Foundation</a></li>
<li id="menu-item-696" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-696"><a href="https://volumio.org/">Volumio</a></li>
</ul>
</li>
</ul>
</li>
<li id="menu-item-58" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58"><a href="https://www.pine64.org/gettings-started/">Getting Started</a></li>
<li id="menu-item-57" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57"><a href="https://www.pine64.org/philosophy/">Philosophy</a></li>
<li id="menu-item-205" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-205"><a href="https://store.pine64.org/?post_type=product">Store</a></li>
</ul></div> </nav>
<div class="np-header-search-wrapper">
<span class="search-main"><i class="fa fa-search"></i></span>
<div class="search-form-main np-clearfix">
<form role="search" method="get" class="search-form" action="https://www.pine64.org/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form> </div>
</div>
</div>
</div>
</div>
</header>
<div id="content" class="site-content">
<div class="mt-container">
<div id="primary" class="content-area">
<main id="main" class="site-main" role="main">
<article id="post-1785" class="post-1785 post type-post status-publish format-standard hentry category-community category-hardrock64 category-news category-pinebook-pro category-pinephone category-pinetab tag-community tag-pinebook-pro tag-pinephone tag-pinetab">
<div class="np-article-thumb">
</div>
<header class="entry-header">
<h1 class="entry-title">February Update: Post CNY and FOSDEM Status Report</h1> <div class="post-cats-list">
<span class="category-button np-cat-8"><a href="https://www.pine64.org/category/community/">Community</a></span>
<span class="category-button np-cat-53"><a href="https://www.pine64.org/category/hardrock64/">HardROCK64</a></span>
<span class="category-button np-cat-10"><a href="https://www.pine64.org/category/news/">News</a></span>
<span class="category-button np-cat-12"><a href="https://www.pine64.org/category/pinebook-pro/">Pinebook Pro</a></span>
<span class="category-button np-cat-11"><a href="https://www.pine64.org/category/pinephone/">PinePhone</a></span>
<span class="category-button np-cat-30"><a href="https://www.pine64.org/category/pinetab/">PineTab</a></span>
</div>
<div class="entry-meta">
<span class="posted-on"><a href="https://www.pine64.org/2020/02/15/february-update-post-cny-and-fosdem-status-report/" rel="bookmark"><time class="entry-date published" datetime="2020-02-15T21:57:53+00:00">February 15, 2020</time><time class="updated" datetime="2020-02-15T23:31:59+00:00">February 15, 2020</time></a></span><span class="byline"><span class="author vcard"><a class="url fn n" href="https://www.pine64.org/author/lukasz/">Lukasz Erecinski</a></span></span><span class="comments-link"><a href="https://www.pine64.org/2020/02/15/february-update-post-cny-and-fosdem-status-report/#comments">15 Comments<span class="screen-reader-text"> on February Update: Post CNY and FOSDEM Status Report</span></a></span> </div>
</header>
<div class="entry-content">
<div data-elementor-type="wp-post" data-elementor-id="1785" class="elementor elementor-1785" data-elementor-settings="[]">
<div class="elementor-inner">
<div class="elementor-section-wrap">
<section class="elementor-element elementor-element-ddde63f elementor-section-boxed elementor-section-height-default elementor-section-height-default elementor-section elementor-top-section" data-id="ddde63f" data-element_type="section">
<div class="elementor-container elementor-column-gap-default">
<div class="elementor-row">
<div class="elementor-element elementor-element-24956aa elementor-column elementor-col-100 elementor-top-column" data-id="24956aa" data-element_type="column">
<div class="elementor-column-wrap  elementor-element-populated">
<div class="elementor-widget-wrap">
<div class="elementor-element elementor-element-4c083b5 elementor-widget elementor-widget-image" data-id="4c083b5" data-element_type="widget" data-widget_type="image.default">
<div class="elementor-widget-container">
<div class="elementor-image">
<img width="1333" height="1000" src="https://www.pine64.org/wp-content/uploads/2020/02/Header.jpg" class="attachment-full size-full" alt="" /> </div>
</div>
</div>
<div class="elementor-element elementor-element-d06d4ca elementor-widget elementor-widget-text-editor" data-id="d06d4ca" data-element_type="widget" data-widget_type="text-editor.default">
<div class="elementor-widget-container">
<div class="elementor-text-editor elementor-clearfix"><p style="text-align: center;"><strong>Nemo Mobile and Ubuntu Touch on the PinePhone at FOSDEM 2020</strong></p></div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</section>
<section class="elementor-element elementor-element-359b699 elementor-section-boxed elementor-section-height-default elementor-section-height-default elementor-section elementor-top-section" data-id="359b699" data-element_type="section">
<div class="elementor-container elementor-column-gap-default">
<div class="elementor-row">
<div class="elementor-element elementor-element-1759f63 elementor-column elementor-col-100 elementor-top-column" data-id="1759f63" data-element_type="column">
<div class="elementor-column-wrap  elementor-element-populated">
<div class="elementor-widget-wrap">
<div class="elementor-element elementor-element-06ca9b5 elementor-widget elementor-widget-text-editor" data-id="06ca9b5" data-element_type="widget" data-widget_type="text-editor.default">
<div class="elementor-widget-container">
<div class="elementor-text-editor elementor-clearfix"><p>A lot has happened in the past month. PinePhones have finally begun arriving in the hands of their owners, we had a great showing at FOSDEM, and new hardware was announced. If you haven’t yet read <a href="https://www.pine64.org/2020/02/03/fosdem-2020-and-hardware-announcements/">my post about our trip to FOSDEM and the new devices</a>, then I encourage you to do so. Behind the scenes, much work is currently being poured into consolidating and evolving current projects as well as exploring new ones. There are some really exciting months ahead of us! </p><p>In the meantime, we have plenty to discuss. </p><p><b>Here is this month’s TL:DR</b></p><ul><li>Want to write something for the blog? &#8211; contact me</li><li>Production is at a standstill; hard to estimate how things unfold</li><li>CNY shipping backlog of SBCs &amp; PineTime; HardROCK64 &amp; SOEdge release dates</li><li>Expect production / order delay for Pinebook Pro, PinePhone and PineTab</li><li>Pinebook Pro NVMe adapter fix; new adapter manufactured </li><li>Pinebook Pro OS choice is growing rapidly; custom keyboard firmware</li><li>Pinebook-to-pro upgrade kit delayed (again)</li><li>PinePhone software status &#8211; 4 key areas discussed</li><li>PinePhone FCC/CE certification &amp; hardware changes for production units</li><li>PineTab is coming; factory under lockdown, no insight how far along production is</li></ul></div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</section>
<section class="elementor-element elementor-element-5e7481a elementor-section-boxed elementor-section-height-default elementor-section-height-default elementor-section elementor-top-section" data-id="5e7481a" data-element_type="section">
<div class="elementor-container elementor-column-gap-default">
<div class="elementor-row">
<div class="elementor-element elementor-element-eb1c148 elementor-column elementor-col-100 elementor-top-column" data-id="eb1c148" data-element_type="column">
<div class="elementor-column-wrap  elementor-element-populated">
<div class="elementor-widget-wrap">
<div class="elementor-element elementor-element-64fee75 elementor-widget elementor-widget-text-editor" data-id="64fee75" data-element_type="widget" data-widget_type="text-editor.default">
<div class="elementor-widget-container">
<div class="elementor-text-editor elementor-clearfix"><h5><b>Write something for the blog</b></h5>
<p>I’d like to quickly remind everyone that this blog is open to everyone to publish on. If you are working on something exciting and wish to share it with the community then get in touch with me &#8211; I’ll set up an account for you. As an enticement I’ll add that this blog gets a lot of traffic, so it is a great way for get exposure for whatever you’re working on. It also provides you with an opportunity to receive detailed feedback on your work or even get people to join your efforts.</p></div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</section>
<section class="elementor-element elementor-element-411c0f9 elementor-section-boxed elementor-section-height-default elementor-section-height-default elementor-section elementor-top-section" data-id="411c0f9" data-element_type="section">
<div class="elementor-container elementor-column-gap-default">
<div class="elementor-row">
<div class="elementor-element elementor-element-669ed8d elementor-column elementor-col-100 elementor-top-column" data-id="669ed8d" data-element_type="column">
<div class="elementor-column-wrap  elementor-element-populated">
<div class="elementor-widget-wrap">
<div class="elementor-element elementor-element-981cf23 elementor-widget elementor-widget-text-editor" data-id="981cf23" data-element_type="widget" data-widget_type="text-editor.default">
<div class="elementor-widget-container">
<div class="elementor-text-editor elementor-clearfix"><h5><b>Housekeeping Part 1: 2019-nCov Pandemic </b></h5><p>There were a couple of things I initially wanted to discuss in this section, but the situation warrants me to focus on the most important topic. And so the main topic on the housekeeping agenda relates to the outbreak of the 2019-nCov Coronavirus and the impact it has on the Guangdong province as well as Hong Kong. For those who do not know, PINE64 devices are produced in the city of Shenzhen located in the Guangdong province, and all equipment with batteries &#8211; such as the Pinebook Pro or PinePhone &#8211; ships out from Hong Kong.  </p><p>As some of you may already know from my <a href="https://forum.pine64.org/showthread.php?tid=8956">post</a> on the forums, earlier this month Guangdong issued a restrictive order prohibiting work from resuming until February 10th. While, in theory, companies are now allowed to resume business, in practice everything remains at a complete standstill. In other words, our operations and those of our partners as well as factories have not resumed as of today. For a variety of reasons, there is also a limit to how much work our staff can do at the moment. </p><p>Factories producing the PinePhone, PineTab and Pinebook Pro remain closed because they need to undergo a long and complicated procedure that will allow them to resume operation. However, due to the huge volume of such government sanctioned procedures required province-wide, it may yet some time before people can even enter the factory. It&#8217;s worth pointing out that this issue can also be felt up the entire supply chain &#8211; manufacturers of components are also affected by this, and shortages are expected.</p><p>Sadly, this isn’t the entire extent of the problem; as I’ve already mentioned, all devices which contain batteries ship from Hong Kong. Earlier this month Hong Kong closed many key crossings to the region from mainland China, including the one which we rely on, and now there is a 2-week long quarantine for anyone arriving from mainland China to Hong Kong. This means that our shipping staff can’t reach the Hong Kong warehouse. </p><p>So, then, what does all this mean in practice? It means that we cannot produce anything this month and, even if we could, there is no way for us to ship any devices with batteries. I will refrain from speculating as to when things will return to normal. Expect shipping dates to slip considerably. I have a suspicion that the extent of this disturbance will be felt across the entire electronics industry for the rest of the year. </p><p>I will keep you updated the best I can in the previously linked thread; the moment I know something I’ll make sure to create a new post and update the original entry.</p></div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</section>
<section class="elementor-element elementor-element-a80eaaa elementor-section-boxed elementor-section-height-default elementor-section-height-default elementor-section elementor-top-section" data-id="a80eaaa" data-element_type="section">
<div class="elementor-container elementor-column-gap-default">
<div class="elementor-row">
<div class="elementor-element elementor-element-908c58e elementor-column elementor-col-100 elementor-top-column" data-id="908c58e" data-element_type="column">
<div class="elementor-column-wrap  elementor-element-populated">
<div class="elementor-widget-wrap">
<div class="elementor-element elementor-element-354788a elementor-widget elementor-widget-text-editor" data-id="354788a" data-element_type="widget" data-widget_type="text-editor.default">
<div class="elementor-widget-container">
<div class="elementor-text-editor elementor-clearfix"><h5><b>Housekeeping Part 2: Chinese New Year Shipping Backlog </b></h5><p>We’re currently catching up on the Chinese New Year shipping backlog. While we’re unable to produce more devices at this time, we can ship existing single board computers as well as the PineTime dev kit from mainland China. Despite the shipping team being severely crippled by current circumstances and the resulting lack of available staff, I expect parcels to keep on steadily going out throughout next week. As I understand it, the process of clearing out the backlog has already begun a few days ago and should be completed shortly. If you’ve ordered a PINE64 single board computer or PineTime dev kit after January 20th then your order should be en route shortly. </p><p>As for the production and availability of the HardROCK64 and SOEdge AI module announced at this year’s FOSDEM &#8211; we already accounted for the disruption caused by the pandemic. We also purposefully provided approximate availability dates as it is literally impossible to predict how the situation will unfold. Regardless, the tentative availability dates of April/May 2020 are unaltered at this time.    </p></div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</section>
<section class="elementor-element elementor-element-fd912c5 elementor-section-boxed elementor-section-height-default elementor-section-height-default elementor-section elementor-top-section" data-id="fd912c5" data-element_type="section">
<div class="elementor-container elementor-column-gap-default">
<div class="elementor-row">
<div class="elementor-element elementor-element-558c059 elementor-column elementor-col-100 elementor-top-column" data-id="558c059" data-element_type="column">
<div class="elementor-column-wrap  elementor-element-populated">
<div class="elementor-widget-wrap">
<div class="elementor-element elementor-element-b555516 elementor-widget elementor-widget-text-editor" data-id="b555516" data-element_type="widget" data-widget_type="text-editor.default">
<div class="elementor-widget-container">
<div class="elementor-text-editor elementor-clearfix"><h5><b>Pinebook Pro<br /></b></h5></div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</section>
<section class="elementor-element elementor-element-fa025db elementor-section-boxed elementor-section-height-default elementor-section-height-default elementor-section elementor-top-section" data-id="fa025db" data-element_type="section">
<div class="elementor-container elementor-column-gap-default">
<div class="elementor-row">
<div class="elementor-element elementor-element-4e843a3 elementor-column elementor-col-100 elementor-top-column" data-id="4e843a3" data-element_type="column">
<div class="elementor-column-wrap  elementor-element-populated">
<div class="elementor-widget-wrap">
<div class="elementor-element elementor-element-d80fbce elementor-widget elementor-widget-text-editor" data-id="d80fbce" data-element_type="widget" data-widget_type="text-editor.default">
<div class="elementor-widget-container">
<div class="elementor-text-editor elementor-clearfix"><p>There is plenty of good news, but let us start with the bad. The bad news is that we need to postpone the production of the RK3399 upgrade kit for the original Pinebook once again. Don’t worry, we’re not shelving it, we’re just prioritizing other things &#8211; such as the newly announced HardROCK64 and SOEdge &#8211; due to the limited manufacturing capacity (caused by the aforementioned pandemic in China). Having already postponed the release of the upgrade kit thrice now, I rather not promise something for a fourth time. Instead I’ll say: it&#8217;s in the works, and as soon as I know something with a high degree of certainty I’ll make sure to let you all know.&nbsp;</p>
<p>On to better news. We now have a solution to the original NVMe adapter problems, where the adapter with an NVMe SSD would not fit properly in the laptop chassis. The solution was surprisingly simple, but required us to manufacture a custom holder for the SSD. I apologize for not keeping you up-to-date on the status of this solution; I didn’t post anything on the subject because I had no insight into the process. If you have the original NVMe adapter for the Pinebook Pro, please send an email to <a href="https://www.pine64.org/info@pine64.org"><span class="__cf_email__" data-cfemail="0a63646c654a7a63646f3c3e2465786d">[email&#160;protected]</span></a> with the following in the subject field:&nbsp;</p>
<p><strong><span style="text-decoration: underline;"><i>Subject: New PBP NVMe adapter holder [original order number]</i></span></strong></p>
<p>We have now also created a new optional NVMe adapter that will ship with all future Pinebook Pro orders. The new adapter is a little longer, but has a lower profile, and is perfectly aligned with the mounting holes inside the Pinebook Pro chassis. I am told that it has been fitted with a variety of popular NVMe SSDs and no issues were encountered.&nbsp;</p></div>
</div>
</div>
<div class="elementor-element elementor-element-41cb660 elementor-widget elementor-widget-image" data-id="41cb660" data-element_type="widget" data-widget_type="image.default">
<div class="elementor-widget-container">
<div class="elementor-image">
<img width="1280" height="957" src="https://www.pine64.org/wp-content/uploads/2020/02/newadapter.jpeg" class="attachment-full size-full" alt="" /> </div>
</div>
</div>
<div class="elementor-element elementor-element-9544288 elementor-widget elementor-widget-text-editor" data-id="9544288" data-element_type="widget" data-widget_type="text-editor.default">
<div class="elementor-widget-container">
<div class="elementor-text-editor elementor-clearfix"><p style="text-align: center;"><strong>New NVMe PCIe adapter top / old NVMe PCIe adapter bottom</strong></p></div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</section>
<section class="elementor-element elementor-element-786f615 elementor-section-boxed elementor-section-height-default elementor-section-height-default elementor-section elementor-top-section" data-id="786f615" data-element_type="section">
<div class="elementor-container elementor-column-gap-default">
<div class="elementor-row">
<div class="elementor-element elementor-element-9b9eedb elementor-column elementor-col-100 elementor-top-column" data-id="9b9eedb" data-element_type="column">
<div class="elementor-column-wrap  elementor-element-populated">
<div class="elementor-widget-wrap">
<div class="elementor-element elementor-element-81b24af elementor-widget elementor-widget-text-editor" data-id="81b24af" data-element_type="widget" data-widget_type="text-editor.default">
<div class="elementor-widget-container">
<div class="elementor-text-editor elementor-clearfix"><p>The other piece of good news is that the past 30 days have seen many OS releases. We now also have a choice to run Kali Linux, Gentoo, OpenSUSE, Fedora, NetBSD and postmarketOS (Alpine Linux) on the Pinebook Pro. Most of these OSes have been added to the <a href="https://wiki.pine64.org/index.php/Pinebook_Pro_Software_Release">Pinebook Pro Software Releases</a> subsection on our Wiki. I highly suspect that the coming days will see yet more software releases for the Pinebook Pro, including other *BSD systems. This is obviously good and welcome news, since broad support for the Pinebook Pro means more people interested in the project. Personally, I have been running Manjaro with KDE desktop in the recent weeks and the experience has been nothing short of great. If you’re considering running Manjaro KDE edition, I suggest you enable OpenGL desktop acceleration via the Panfrost FOSS GPU driver, it makes the installation fly. This can be achieved using <a href="https://github.com/McMarius11/Pinebook-Pro/blob/master/graphics_driver_pf_fb.sh">this script</a>. </p></div>
</div>
</div>
<div class="elementor-element elementor-element-0cb5574 elementor-widget elementor-widget-image" data-id="0cb5574" data-element_type="widget" data-widget_type="image.default">
<div class="elementor-widget-container">
<div class="elementor-image">
<img width="1320" height="1000" src="https://www.pine64.org/wp-content/uploads/2020/02/OS-List.jpg" class="attachment-full size-full" alt="" /> </div>
</div>
</div>
<div class="elementor-element elementor-element-3fdd1fe elementor-widget elementor-widget-text-editor" data-id="3fdd1fe" data-element_type="widget" data-widget_type="text-editor.default">
<div class="elementor-widget-container">
<div class="elementor-text-editor elementor-clearfix"><p style="text-align: center;"><strong>Growing Pinebook Pro OS List</strong> </p></div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</section>
<section class="elementor-element elementor-element-fc892d7 elementor-section-boxed elementor-section-height-default elementor-section-height-default elementor-section elementor-top-section" data-id="fc892d7" data-element_type="section">
<div class="elementor-container elementor-column-gap-default">
<div class="elementor-row">
<div class="elementor-element elementor-element-a3d3bec elementor-column elementor-col-100 elementor-top-column" data-id="a3d3bec" data-element_type="column">
<div class="elementor-column-wrap  elementor-element-populated">
<div class="elementor-widget-wrap">
<div class="elementor-element elementor-element-61b01ee elementor-widget elementor-widget-text-editor" data-id="61b01ee" data-element_type="widget" data-widget_type="text-editor.default">
<div class="elementor-widget-container">
<div class="elementor-text-editor elementor-clearfix"><p>Lastly, I’d like to give a huge shoutout to <a href="https://github.com/jackhumbert">Jack Humbert</a> for his work on the Pinebook Pro’s keyboard firmware. Jack made it possible to <a href="https://github.com/jackhumbert/pinebook-pro-keyboard-updater/tree/master/firmware/src">create your own custom keymaps</a> for the keyboard, significantly enhancing the potential functionality of the laptop. Just as an example, one user has created and shared theirs <a href="https://forum.pine64.org/showthread.php?tid=8884&amp;pid=59150#pid59150">ANSI Dvorak layout</a> that supposedly can be used without any problems. It is always exciting to see community members embrace and improve upon implementations which we have given considerable thought to. If you have any questions regarding the process of creating your own custom keymap then I redirect you to the dedicated <a href="https://forum.pine64.org/showthread.php?tid=8884&amp;highlight=firmware">forum thread</a> discussing the custom firmware implementation. </p><p>Before I move onto the next section let me quickly address the elephant in the room; many of you are asking when the next production-run of the Pinebook Pro will commence. We initially intended for new Pinebook Pros to be produced this month, with pre-orders opening now(ish). As I already explained in the housekeeping section, this will not happen. I can only offer you my guess at this point &#8211; and that is that the next pre-order window will open mid-March.</p></div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</section>
<section class="elementor-element elementor-element-06abef9 elementor-section-boxed elementor-section-height-default elementor-section-height-default elementor-section elementor-top-section" data-id="06abef9" data-element_type="section">
<div class="elementor-container elementor-column-gap-default">
<div class="elementor-row">
<div class="elementor-element elementor-element-ae7efda elementor-column elementor-col-100 elementor-top-column" data-id="ae7efda" data-element_type="column">
<div class="elementor-column-wrap  elementor-element-populated">
<div class="elementor-widget-wrap">
<div class="elementor-element elementor-element-3595692 elementor-widget elementor-widget-text-editor" data-id="3595692" data-element_type="widget" data-widget_type="text-editor.default">
<div class="elementor-widget-container">
<div class="elementor-text-editor elementor-clearfix"><h5><b>PinePhone</b></h5></div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</section>
<section class="elementor-element elementor-element-93ffd05 elementor-section-boxed elementor-section-height-default elementor-section-height-default elementor-section elementor-top-section" data-id="93ffd05" data-element_type="section">
<div class="elementor-container elementor-column-gap-default">
<div class="elementor-row">
<div class="elementor-element elementor-element-1936dd0 elementor-column elementor-col-100 elementor-top-column" data-id="1936dd0" data-element_type="column">
<div class="elementor-column-wrap  elementor-element-populated">
<div class="elementor-widget-wrap">
<div class="elementor-element elementor-element-76437fc elementor-widget elementor-widget-text-editor" data-id="76437fc" data-element_type="widget" data-widget_type="text-editor.default">
<div class="elementor-widget-container">
<div class="elementor-text-editor elementor-clearfix"><p>Many Brave Heart edition PinePhones, with the exception of those slated for Germany, have already reached their destination. So far the reception from end-users has been very positive, which admittedly makes me rather thrilled. I’d also like to thank those of you who post previews, reviews, quick-looks, etc. online; every single written or recorded piece of content that I’ve seen insofar has rightfully included a mention that the PinePhone is a work-in-progress. This is important since, as I see it, the most important aspect of the project currently is showcasing progress while accurately depicting the current state of the software options. </p><p>Speaking of PinePhone software options and development status, there is so much information to cover that it would require an entire separate post. Not to mention that I am not the most competent person to cover the subject of software development in the first place. So, instead, what I will do in this section is highlight some of the vital developments of the past couple of weeks. </p></div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</section>
<section class="elementor-element elementor-element-52d5555 elementor-section-boxed elementor-section-height-default elementor-section-height-default elementor-section elementor-top-section" data-id="52d5555" data-element_type="section">
<div class="elementor-container elementor-column-gap-default">
<div class="elementor-row">
<div class="elementor-element elementor-element-2aa3753 elementor-column elementor-col-100 elementor-top-column" data-id="2aa3753" data-element_type="column">
<div class="elementor-column-wrap  elementor-element-populated">
<div class="elementor-widget-wrap">
<div class="elementor-element elementor-element-853e6d7 elementor-widget elementor-widget-text-editor" data-id="853e6d7" data-element_type="widget" data-widget_type="text-editor.default">
<div class="elementor-widget-container">
<div class="elementor-text-editor elementor-clearfix"><p>I want to address 4 main topics: 1) battery life; 2) voice calls; 3) camera implementation; 4) performance. Let’s go down the list one-by-one. There are many things pertaining to battery life that are currently being ironed out. On the one hand, a fair bit of work on the AXP803 power management controller and kernel behaviour. I only understand the latter, so I’ll comment on that. Marius from UBports has started experimenting with having the kernel downclock the core frequency, drop the CPU voltage and turn off 3 cores when the phone’s display is off (in its idle state). This early experimentation has resulted in a stand-by time of approximately 12hrs, which is rather impressive for a first battery-preserving attempt. This will only get better with time, as it becomes paired with more advanced power management. Another developer, Megi, has also managed to dramatically lower the WiFi module’s power consumption, which can buy users as much as another hour of runtime during active use.</p></div>
</div>
</div>
<div class="elementor-element elementor-element-1cfb960 elementor-widget elementor-widget-image" data-id="1cfb960" data-element_type="widget" data-widget_type="image.default">
<div class="elementor-widget-container">
<div class="elementor-image">
<img width="640" height="587" src="https://www.pine64.org/wp-content/uploads/2020/02/power.png" class="attachment-large size-large" alt="" /> </div>
</div>
</div>
<div class="elementor-element elementor-element-439353f elementor-widget elementor-widget-text-editor" data-id="439353f" data-element_type="widget" data-widget_type="text-editor.default">
<div class="elementor-widget-container">
<div class="elementor-text-editor elementor-clearfix"><p style="text-align: center;"><strong>Picture showing battery drain over ~11 hrs on the PinePhone running Ubuntu Touch</strong></p></div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</section>
<section class="elementor-element elementor-element-2e187f2 elementor-section-boxed elementor-section-height-default elementor-section-height-default elementor-section elementor-top-section" data-id="2e187f2" data-element_type="section">
<div class="elementor-container elementor-column-gap-default">
<div class="elementor-row">
<div class="elementor-element elementor-element-970978f elementor-column elementor-col-100 elementor-top-column" data-id="970978f" data-element_type="column">
<div class="elementor-column-wrap  elementor-element-populated">
<div class="elementor-widget-wrap">
<div class="elementor-element elementor-element-f62c5d4 elementor-widget elementor-widget-text-editor" data-id="f62c5d4" data-element_type="widget" data-widget_type="text-editor.default">
<div class="elementor-widget-container">
<div class="elementor-text-editor elementor-clearfix"><p>Megi has also demoed voice calls and camera implementation in the past few weeks. While voice calls already work, they also require manual audio routing (for those interested, <a href="https://megous.com/dl/tmp/modem.txt">here</a> are the details). Getting voice calls functional with the individual OSes is being worked on, of course, but there is no telling when the functionality will be available. It could be soon or in a few weeks or months. The story is very similar for both the front and back camera. We have seen a successful demo of the cameras being used from the userspace, but this functionality remains to be implemented into the existing OSes. Out of the two highly desirable features, it is my understanding that voice calls will be easier to implement within a short-to-medium amount of time. </p></div>
</div>
</div>
<div class="elementor-element elementor-element-1e38026 elementor-aspect-ratio-169 elementor-widget elementor-widget-video" data-id="1e38026" data-element_type="widget" data-settings="{&quot;aspect_ratio&quot;:&quot;169&quot;}" data-widget_type="video.default">
<div class="elementor-widget-container">
<div class="elementor-wrapper elementor-fit-aspect-ratio elementor-open-inline">
<iframe class="elementor-video-iframe" allowfullscreen title="youtube Video Player" src="https://www.youtube.com/embed/12bsEtUEWbg?feature=oembed&amp;start&amp;end&amp;wmode=opaque&amp;loop=0&amp;controls=1&amp;mute=0&amp;rel=0&amp;modestbranding=0"></iframe> </div>
</div>
</div>
<div class="elementor-element elementor-element-5ecff1d elementor-widget elementor-widget-text-editor" data-id="5ecff1d" data-element_type="widget" data-widget_type="text-editor.default">
<div class="elementor-widget-container">
<div class="elementor-text-editor elementor-clearfix"><p style="text-align: center;"><strong>Phone call from Arch Linux on PinePhone ~ Megi</strong></p></div>
</div>
</div>
<div class="elementor-element elementor-element-0a822b8 elementor-aspect-ratio-169 elementor-widget elementor-widget-video" data-id="0a822b8" data-element_type="widget" data-settings="{&quot;aspect_ratio&quot;:&quot;169&quot;}" data-widget_type="video.default">
<div class="elementor-widget-container">
<div class="elementor-wrapper elementor-fit-aspect-ratio elementor-open-inline">
<iframe class="elementor-video-iframe" allowfullscreen title="youtube Video Player" src="https://www.youtube.com/embed/l-Vt8-npTjc?feature=oembed&amp;start&amp;end&amp;wmode=opaque&amp;loop=0&amp;controls=1&amp;mute=0&amp;rel=0&amp;modestbranding=0"></iframe> </div>
</div>
</div>
<div class="elementor-element elementor-element-1e3525e elementor-widget elementor-widget-text-editor" data-id="1e3525e" data-element_type="widget" data-widget_type="text-editor.default">
<div class="elementor-widget-container">
<div class="elementor-text-editor elementor-clearfix"><p style="text-align: center;"><strong>Camera Test application on the PinePhone ~ Megi</strong></p></div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</section>
<section class="elementor-element elementor-element-befbed7 elementor-section-boxed elementor-section-height-default elementor-section-height-default elementor-section elementor-top-section" data-id="befbed7" data-element_type="section">
<div class="elementor-container elementor-column-gap-default">
<div class="elementor-row">
<div class="elementor-element elementor-element-d75f785 elementor-column elementor-col-100 elementor-top-column" data-id="d75f785" data-element_type="column">
<div class="elementor-column-wrap  elementor-element-populated">
<div class="elementor-widget-wrap">
<div class="elementor-element elementor-element-dac4bab elementor-widget elementor-widget-text-editor" data-id="dac4bab" data-element_type="widget" data-widget_type="text-editor.default">
<div class="elementor-widget-container">
<div class="elementor-text-editor elementor-clearfix"><p>Last on the PinePhone software agenda is the subject of performance. To be precise, the end-user experience of using the phone &#8211; the responsiveness of the UI. This is one area where you can expect a lot of changes from one week to another. As an example, KDE Neon from early February suffered from poor performance, making it borderline unusable. Less than two weeks later, the newest KDE Neon OS image is one of the fastest out there (despite it being highly unstable). Similarly, Ubuntu Touch suffers from a significant amount of slow-down in the main UI. This is caused, funny enough, by the wallpaper; replace the wallpaper (for the one with puppies as an example) and watch the performance significantly improve.  Such performance issues are very much expected at this point in time, but I expect that their root causes will be found and ironed out relatively soon.</p><p>Many users have asked why there is little to no dev dialogue in the #PinePhone chat. For those who don’t know, the #PinePhone channel is very active. There are ~2400 users in Discord, ~100 (concurrent) users in IRC, ~800 users in Telegram and ~500 users in Matrix. This makes for an environment where it’s very difficult to hold a frequently complex and technical conversation. Development-related chat is very much ongoing, but it’s mostly taking place elsewhere. This does not mean, however, that you can’t ask devs questions or engage with them &#8211; they are still in the main channel if you need them. </p></div>
</div>
</div>
<div class="elementor-element elementor-element-c8dbab0 elementor-aspect-ratio-169 elementor-widget elementor-widget-video" data-id="c8dbab0" data-element_type="widget" data-settings="{&quot;aspect_ratio&quot;:&quot;169&quot;}" data-widget_type="video.default">
<div class="elementor-widget-container">
<div class="elementor-wrapper elementor-fit-aspect-ratio elementor-open-inline">
<iframe class="elementor-video-iframe" allowfullscreen title="youtube Video Player" src="https://www.youtube.com/embed/xI6AUFkQJU0?feature=oembed&amp;start&amp;end&amp;wmode=opaque&amp;loop=0&amp;controls=1&amp;mute=0&amp;rel=0&amp;modestbranding=0"></iframe> </div>
</div>
</div>
<div class="elementor-element elementor-element-4795c7a elementor-widget elementor-widget-text-editor" data-id="4795c7a" data-element_type="widget" data-widget_type="text-editor.default">
<div class="elementor-widget-container">
<div class="elementor-text-editor elementor-clearfix"><p style="text-align: center;"><strong>postmarketOS with Phosh performing rather well in newest OS image ~ <a href="https://www.youtube.com/channel/UC9LBZMUotYSPsguBkd5eMnA">Alexmitter</a></strong></p></div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</section>
<section class="elementor-element elementor-element-0153399 elementor-section-boxed elementor-section-height-default elementor-section-height-default elementor-section elementor-top-section" data-id="0153399" data-element_type="section">
<div class="elementor-container elementor-column-gap-default">
<div class="elementor-row">
<div class="elementor-element elementor-element-14de6c9 elementor-column elementor-col-100 elementor-top-column" data-id="14de6c9" data-element_type="column">
<div class="elementor-column-wrap  elementor-element-populated">
<div class="elementor-widget-wrap">
<div class="elementor-element elementor-element-5ec634b elementor-widget elementor-widget-text-editor" data-id="5ec634b" data-element_type="widget" data-widget_type="text-editor.default">
<div class="elementor-widget-container">
<div class="elementor-text-editor elementor-clearfix"><p>The last bit of information related to the PinePhone I wish to discuss before proceeding to the next section concerns consumer-grade PinePhone changes and CE/ FCC certification. We expect to have the certifications in place later this month, which means that all future PinePhones will ship as certified devices. This is good news, since some places such as Germany require this type of certification on consumer products. As for changes to the hardware, there is a <a href="https://wiki.pine64.org/index.php/PinePhone_v1.1_-_Braveheart">list of errata</a> on the Wiki. To be clear, most of these issues are imperfect hardware implementations rather than major problems. We’ll work though as many of these errata for the final phone as possible while striving to maintain complete software compatibility with Braveheart phones. </p><p>Similarly to the Pinebook Pro, we initially intended to start the production of the phones this month. As I’ve already explained in previous sections, it is much more likely that production will first begin in March. On the positive side, we have some super exciting things in stock for the PinePhone which we will be sharing with you shortly; we trust that this will more than make up for the pandemic-related manufacturing delays. </p></div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</section>
<section class="elementor-element elementor-element-7001361 elementor-section-boxed elementor-section-height-default elementor-section-height-default elementor-section elementor-top-section" data-id="7001361" data-element_type="section">
<div class="elementor-container elementor-column-gap-default">
<div class="elementor-row">
<div class="elementor-element elementor-element-2bce558 elementor-column elementor-col-100 elementor-top-column" data-id="2bce558" data-element_type="column">
<div class="elementor-column-wrap  elementor-element-populated">
<div class="elementor-widget-wrap">
<div class="elementor-element elementor-element-b6ea51f elementor-widget elementor-widget-text-editor" data-id="b6ea51f" data-element_type="widget" data-widget_type="text-editor.default">
<div class="elementor-widget-container">
<div class="elementor-text-editor elementor-clearfix"><h5><b>PineTab</b></h5><p>This section of the update will be rather short since not much has changed since last month. Production of the PineTab early adopter units started prior to Chinese New Year, but due to the factory currently being locked-down and staff unable to access it, we do not know how far along the production process got in January. If we can resume PineTab manufacturing next month alongside the PinePhone and Pinebook Pro, then pre-orders may go live in March. I’ll make sure to amend this post with an edit once we know the state of production. </p><p>The good news is that we have now internally narrowed down OS choice for this early batch to two OSes. We’re in talks with the projects in question to determine which of the two will be the most viable for the first PineTab batch. I expect that we should be announcing what we agreed on next month, so if you’re interested in the PineTab now is probably the right time to subscribe to this blog. At any rate, there are now two good options for us to choose from with sufficient software maturity that early adopters have something to start with when they receive their unit.</p><p>This wraps it up for this month’s community update. I hope to be back with better news next month. In the meantime, we have some important and exciting things coming in the next couple of weeks, so make sure to subscribe to the blog and stay tuned for the upcoming announcements!</p></div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</section>
</div>
</div>
</div>
</div>
<footer class="entry-footer">
<span class="tags-links">Tagged <a href="https://www.pine64.org/tag/community/" rel="tag">community</a><a href="https://www.pine64.org/tag/pinebook-pro/" rel="tag">Pinebook Pro</a><a href="https://www.pine64.org/tag/pinephone/" rel="tag">PinePhone</a><a href="https://www.pine64.org/tag/pinetab/" rel="tag">PineTab</a></span> </footer>
</article>
<nav class="navigation post-navigation" role="navigation" aria-label="Posts">
<h2 class="screen-reader-text">Post navigation</h2>
<div class="nav-links"><div class="nav-previous"><a href="https://www.pine64.org/2020/02/03/fosdem-2020-and-hardware-announcements/" rel="prev">FOSDEM 2020 and Hardware Announcements</a></div></div>
</nav><div class="np-related-section-wrapper"><h2 class="np-related-title np-clearfix">Related Posts</h2><div class="np-related-posts-wrap np-clearfix"> <div class="np-single-post np-clearfix">
<div class="np-post-thumb">
<a href="https://www.pine64.org/2019/05/13/taking-retoemulation-to-the-next-level-with-rockpro64-and-roshambo/">
</a>
</div>
<div class="np-post-content">
<h3 class="np-post-title small-size"><a href="https://www.pine64.org/2019/05/13/taking-retoemulation-to-the-next-level-with-rockpro64-and-roshambo/">Taking RetroEmulation to the next level with RockPro64 and Roshambo</a></h3>
<div class="np-post-meta">
<span class="posted-on"><a href="https://www.pine64.org/2019/05/13/taking-retoemulation-to-the-next-level-with-rockpro64-and-roshambo/" rel="bookmark"><time class="entry-date published" datetime="2019-05-13T16:35:27+00:00">May 13, 2019</time><time class="updated" datetime="2019-05-15T15:24:44+00:00">May 15, 2019</time></a></span><span class="byline"><span class="author vcard"><a class="url fn n" href="https://www.pine64.org/author/jimmyrustles/">JimmyRustles</a></span></span> </div>
</div>
</div>
<div class="np-single-post np-clearfix">
<div class="np-post-thumb">
<a href="https://www.pine64.org/2019/11/05/brave-heart-edition-pinephones/">
</a>
</div>
<div class="np-post-content">
<h3 class="np-post-title small-size"><a href="https://www.pine64.org/2019/11/05/brave-heart-edition-pinephones/">November Update: Brave Heart, Pinebook Pro reception and more</a></h3>
<div class="np-post-meta">
<span class="posted-on"><a href="https://www.pine64.org/2019/11/05/brave-heart-edition-pinephones/" rel="bookmark"><time class="entry-date published" datetime="2019-11-05T14:16:31+00:00">November 5, 2019</time><time class="updated" datetime="2019-11-19T01:53:45+00:00">November 19, 2019</time></a></span><span class="byline"><span class="author vcard"><a class="url fn n" href="https://www.pine64.org/author/lukasz/">Lukasz Erecinski</a></span></span> </div>
</div>
</div>
<div class="np-single-post np-clearfix">
<div class="np-post-thumb">
<a href="https://www.pine64.org/2019/05/22/forum-update/">
</a>
</div>
<div class="np-post-content">
<h3 class="np-post-title small-size"><a href="https://www.pine64.org/2019/05/22/forum-update/">Forum Update</a></h3>
<div class="np-post-meta">
<span class="posted-on"><a href="https://www.pine64.org/2019/05/22/forum-update/" rel="bookmark"><time class="entry-date published" datetime="2019-05-22T16:06:53+00:00">May 22, 2019</time><time class="updated" datetime="2019-05-23T23:26:15+00:00">May 23, 2019</time></a></span><span class="byline"><span class="author vcard"><a class="url fn n" href="https://www.pine64.org/author/lukasz/">Lukasz Erecinski</a></span></span> </div>
</div>
</div>
</div></div>
<div id="comments" class="comments-area">
<h2 class="comments-title">
15 thoughts on &ldquo;<span>February Update: Post CNY and FOSDEM Status Report</span>&rdquo; </h2>
<ol class="comment-list">
<li id="comment-1272" class="comment even thread-even depth-1 parent">
<article id="div-comment-1272" class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt='' src='https://secure.gravatar.com/avatar/0a8a165c24ed29b3a196e9dab465794e?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/0a8a165c24ed29b3a196e9dab465794e?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' /> <b class="fn">Loren</b> <span class="says">says:</span> </div>
<div class="comment-metadata">
<a href="https://www.pine64.org/2020/02/15/february-update-post-cny-and-fosdem-status-report/#comment-1272">
<time datetime="2020-02-15T22:07:44+00:00">
February 15, 2020 at 10:07 pm </time>
</a>
</div>
</footer>
<div class="comment-content">
<p>So sad to hear about the coronavirus lockdown. Hopefully this will have minimal effects on Pine64&#8217;s products. On the other hand, it&#8217;s great to hear about the progress on the PinePhone. </p>
<p>Do you think that you will be able to meet the March mass production date?</p>
</div>
<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://www.pine64.org/2020/02/15/february-update-post-cny-and-fosdem-status-report/?replytocom=1272#respond' data-commentid="1272" data-postid="1785" data-belowelement="div-comment-1272" data-respondelement="respond" aria-label='Reply to Loren'>Reply</a></div> </article>
<ol class="children">
<li id="comment-1278" class="comment byuser comment-author-lukasz bypostauthor odd alt depth-2 parent">
<article id="div-comment-1278" class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt='' src='https://secure.gravatar.com/avatar/a1f3fab3b5cfa1427b77133541d179f3?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/a1f3fab3b5cfa1427b77133541d179f3?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' /> <b class="fn">Lukasz Erecinski</b> <span class="says">says:</span> </div>
<div class="comment-metadata">
<a href="https://www.pine64.org/2020/02/15/february-update-post-cny-and-fosdem-status-report/#comment-1278">
<time datetime="2020-02-16T12:32:32+00:00">
February 16, 2020 at 12:32 pm </time>
</a>
</div>
</footer>
<div class="comment-content">
<p>There is no chance that we&#8217;ll make the March production date. But we have some really cool news to make up for the delay.</p>
</div>
<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://www.pine64.org/2020/02/15/february-update-post-cny-and-fosdem-status-report/?replytocom=1278#respond' data-commentid="1278" data-postid="1785" data-belowelement="div-comment-1278" data-respondelement="respond" aria-label='Reply to Lukasz Erecinski'>Reply</a></div> </article>
<ol class="children">
<li id="comment-1282" class="comment even depth-3">
<article id="div-comment-1282" class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt='' src='https://secure.gravatar.com/avatar/0a8a165c24ed29b3a196e9dab465794e?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/0a8a165c24ed29b3a196e9dab465794e?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' /> <b class="fn">Loren</b> <span class="says">says:</span> </div>
<div class="comment-metadata">
<a href="https://www.pine64.org/2020/02/15/february-update-post-cny-and-fosdem-status-report/#comment-1282">
<time datetime="2020-02-16T18:53:13+00:00">
February 16, 2020 at 6:53 pm </time>
</a>
</div>
</footer>
<div class="comment-content">
<p>That&#8217;s unfortunate. But let&#8217;s be optimistic &#8211; now the developers have more time to work on the OSes!</p>
</div>
<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://www.pine64.org/2020/02/15/february-update-post-cny-and-fosdem-status-report/?replytocom=1282#respond' data-commentid="1282" data-postid="1785" data-belowelement="div-comment-1282" data-respondelement="respond" aria-label='Reply to Loren'>Reply</a></div> </article>
</li>
</ol>
</li>
</ol>
</li>
<li id="comment-1273" class="comment odd alt thread-odd thread-alt depth-1 parent">
<article id="div-comment-1273" class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt='' src='https://secure.gravatar.com/avatar/8fa0fd1d4ad35da668a1b51615bf04f6?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/8fa0fd1d4ad35da668a1b51615bf04f6?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' /> <b class="fn">Simon Schubert</b> <span class="says">says:</span> </div>
<div class="comment-metadata">
<a href="https://www.pine64.org/2020/02/15/february-update-post-cny-and-fosdem-status-report/#comment-1273">
<time datetime="2020-02-16T06:48:29+00:00">
February 16, 2020 at 6:48 am </time>
</a>
</div>
</footer>
<div class="comment-content">
<p>Thanks for mentioning the delay for the German deliveries. I was already curious if something went wrong with my order. So I just have to be patient a few more weeks hopefully. Thanks for the update you are doing a great job!</p>
</div>
<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://www.pine64.org/2020/02/15/february-update-post-cny-and-fosdem-status-report/?replytocom=1273#respond' data-commentid="1273" data-postid="1785" data-belowelement="div-comment-1273" data-respondelement="respond" aria-label='Reply to Simon Schubert'>Reply</a></div> </article>
<ol class="children">
<li id="comment-1277" class="comment byuser comment-author-lukasz bypostauthor even depth-2">
<article id="div-comment-1277" class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt='' src='https://secure.gravatar.com/avatar/a1f3fab3b5cfa1427b77133541d179f3?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/a1f3fab3b5cfa1427b77133541d179f3?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' /> <b class="fn">Lukasz Erecinski</b> <span class="says">says:</span> </div>
<div class="comment-metadata">
<a href="https://www.pine64.org/2020/02/15/february-update-post-cny-and-fosdem-status-report/#comment-1277">
<time datetime="2020-02-16T12:31:45+00:00">
February 16, 2020 at 12:31 pm </time>
</a>
</div>
</footer>
<div class="comment-content">
<p>The problem with German orders is how strict the customs are on the certifications. In result, the phones will ship to German end-users once the device is certified.</p>
</div>
<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://www.pine64.org/2020/02/15/february-update-post-cny-and-fosdem-status-report/?replytocom=1277#respond' data-commentid="1277" data-postid="1785" data-belowelement="div-comment-1277" data-respondelement="respond" aria-label='Reply to Lukasz Erecinski'>Reply</a></div> </article>
</li>
</ol>
</li>
<li id="comment-1274" class="comment odd alt thread-even depth-1 parent">
<article id="div-comment-1274" class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt='' src='https://secure.gravatar.com/avatar/f65b868cd03e1285a4c46f9deb8fef63?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/f65b868cd03e1285a4c46f9deb8fef63?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' /> <b class="fn">Simon</b> <span class="says">says:</span> </div>
<div class="comment-metadata">
<a href="https://www.pine64.org/2020/02/15/february-update-post-cny-and-fosdem-status-report/#comment-1274">
<time datetime="2020-02-16T09:41:16+00:00">
February 16, 2020 at 9:41 am </time>
</a>
</div>
</footer>
<div class="comment-content">
<p>Any update on the cube up camera?</p>
</div>
<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://www.pine64.org/2020/02/15/february-update-post-cny-and-fosdem-status-report/?replytocom=1274#respond' data-commentid="1274" data-postid="1785" data-belowelement="div-comment-1274" data-respondelement="respond" aria-label='Reply to Simon'>Reply</a></div> </article>
<ol class="children">
<li id="comment-1275" class="comment even depth-2">
<article id="div-comment-1275" class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt='' src='https://secure.gravatar.com/avatar/f65b868cd03e1285a4c46f9deb8fef63?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/f65b868cd03e1285a4c46f9deb8fef63?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' /> <b class="fn">Simon</b> <span class="says">says:</span> </div>
<div class="comment-metadata">
<a href="https://www.pine64.org/2020/02/15/february-update-post-cny-and-fosdem-status-report/#comment-1275">
<time datetime="2020-02-16T09:42:51+00:00">
February 16, 2020 at 9:42 am </time>
</a>
</div>
</footer>
<div class="comment-content">
<p>Oops cube &#8216;ip&#8217; camera even</p>
</div>
<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://www.pine64.org/2020/02/15/february-update-post-cny-and-fosdem-status-report/?replytocom=1275#respond' data-commentid="1275" data-postid="1785" data-belowelement="div-comment-1275" data-respondelement="respond" aria-label='Reply to Simon'>Reply</a></div> </article>
</li>
<li id="comment-1279" class="comment byuser comment-author-lukasz bypostauthor odd alt depth-2">
<article id="div-comment-1279" class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt='' src='https://secure.gravatar.com/avatar/a1f3fab3b5cfa1427b77133541d179f3?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/a1f3fab3b5cfa1427b77133541d179f3?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' /> <b class="fn">Lukasz Erecinski</b> <span class="says">says:</span> </div>
<div class="comment-metadata">
<a href="https://www.pine64.org/2020/02/15/february-update-post-cny-and-fosdem-status-report/#comment-1279">
<time datetime="2020-02-16T12:33:14+00:00">
February 16, 2020 at 12:33 pm </time>
</a>
</div>
</footer>
<div class="comment-content">
<p>We&#8217;re working on it 🙂 Once there is something worth reporting regrading the CUBE I&#8217;ll make sure to do so.</p>
</div>
<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://www.pine64.org/2020/02/15/february-update-post-cny-and-fosdem-status-report/?replytocom=1279#respond' data-commentid="1279" data-postid="1785" data-belowelement="div-comment-1279" data-respondelement="respond" aria-label='Reply to Lukasz Erecinski'>Reply</a></div> </article>
</li>
</ol>
</li>
<li id="comment-1276" class="comment even thread-odd thread-alt depth-1 parent">
<article id="div-comment-1276" class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt='' src='https://secure.gravatar.com/avatar/f4cb4cdf6b42adc2e8c6e68443fd8a94?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/f4cb4cdf6b42adc2e8c6e68443fd8a94?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' /> <b class="fn">Murak</b> <span class="says">says:</span> </div>
<div class="comment-metadata">
<a href="https://www.pine64.org/2020/02/15/february-update-post-cny-and-fosdem-status-report/#comment-1276">
<time datetime="2020-02-16T12:25:53+00:00">
February 16, 2020 at 12:25 pm </time>
</a>
</div>
</footer>
<div class="comment-content">
<p>Super exiting things you say.. Like a keyboard perhaps?</p>
</div>
<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://www.pine64.org/2020/02/15/february-update-post-cny-and-fosdem-status-report/?replytocom=1276#respond' data-commentid="1276" data-postid="1785" data-belowelement="div-comment-1276" data-respondelement="respond" aria-label='Reply to Murak'>Reply</a></div> </article>
<ol class="children">
<li id="comment-1280" class="comment byuser comment-author-lukasz bypostauthor odd alt depth-2 parent">
<article id="div-comment-1280" class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt='' src='https://secure.gravatar.com/avatar/a1f3fab3b5cfa1427b77133541d179f3?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/a1f3fab3b5cfa1427b77133541d179f3?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' /> <b class="fn">Lukasz Erecinski</b> <span class="says">says:</span> </div>
<div class="comment-metadata">
<a href="https://www.pine64.org/2020/02/15/february-update-post-cny-and-fosdem-status-report/#comment-1280">
<time datetime="2020-02-16T12:34:03+00:00">
February 16, 2020 at 12:34 pm </time>
</a>
</div>
</footer>
<div class="comment-content">
<p>The keyboard will come late this year &#8211; too many obstacles to overcome at this time as is. Once everything is running smoothly, we&#8217;ll start on the keyboard.</p>
</div>
<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://www.pine64.org/2020/02/15/february-update-post-cny-and-fosdem-status-report/?replytocom=1280#respond' data-commentid="1280" data-postid="1785" data-belowelement="div-comment-1280" data-respondelement="respond" aria-label='Reply to Lukasz Erecinski'>Reply</a></div> </article>
<ol class="children">
<li id="comment-1284" class="comment even depth-3">
<article id="div-comment-1284" class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt='' src='https://secure.gravatar.com/avatar/83f9ecc295d6f9a1b5f0b6791f5a62ce?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/83f9ecc295d6f9a1b5f0b6791f5a62ce?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' /> <b class="fn">ert34ge</b> <span class="says">says:</span> </div>
<div class="comment-metadata">
<a href="https://www.pine64.org/2020/02/15/february-update-post-cny-and-fosdem-status-report/#comment-1284">
<time datetime="2020-02-16T19:33:35+00:00">
February 16, 2020 at 7:33 pm </time>
</a>
</div>
</footer>
<div class="comment-content">
<p>I need keyboard with home, PgUp, del insert altgr etc.</p>
</div>
<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://www.pine64.org/2020/02/15/february-update-post-cny-and-fosdem-status-report/?replytocom=1284#respond' data-commentid="1284" data-postid="1785" data-belowelement="div-comment-1284" data-respondelement="respond" aria-label='Reply to ert34ge'>Reply</a></div> </article>
</li>
</ol>
</li>
</ol>
</li>
<li id="comment-1281" class="comment odd alt thread-even depth-1 parent">
<article id="div-comment-1281" class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt='' src='https://secure.gravatar.com/avatar/3858032bada534b00e43a27317e01eb7?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/3858032bada534b00e43a27317e01eb7?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' /> <b class="fn"><a href='https://kristianpaul.org' rel='external nofollow ugc' class='url'>Cristian</a></b> <span class="says">says:</span> </div>
<div class="comment-metadata">
<a href="https://www.pine64.org/2020/02/15/february-update-post-cny-and-fosdem-status-report/#comment-1281">
<time datetime="2020-02-16T14:33:46+00:00">
February 16, 2020 at 2:33 pm </time>
</a>
</div>
</footer>
<div class="comment-content">
<p>Is there still a room to be PineTab early adopter? I dont mind waiting</p>
</div>
<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://www.pine64.org/2020/02/15/february-update-post-cny-and-fosdem-status-report/?replytocom=1281#respond' data-commentid="1281" data-postid="1785" data-belowelement="div-comment-1281" data-respondelement="respond" aria-label='Reply to Cristian'>Reply</a></div> </article>
<ol class="children">
<li id="comment-1286" class="comment byuser comment-author-lukasz bypostauthor even depth-2">
<article id="div-comment-1286" class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt='' src='https://secure.gravatar.com/avatar/a1f3fab3b5cfa1427b77133541d179f3?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/a1f3fab3b5cfa1427b77133541d179f3?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' /> <b class="fn">Lukasz Erecinski</b> <span class="says">says:</span> </div>
<div class="comment-metadata">
<a href="https://www.pine64.org/2020/02/15/february-update-post-cny-and-fosdem-status-report/#comment-1286">
<time datetime="2020-02-16T22:26:40+00:00">
February 16, 2020 at 10:26 pm </time>
</a>
</div>
</footer>
<div class="comment-content">
<p>Once we know that how far along the PineTab production is then we&#8217;ll open pre-orders for it.</p>
</div>
<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://www.pine64.org/2020/02/15/february-update-post-cny-and-fosdem-status-report/?replytocom=1286#respond' data-commentid="1286" data-postid="1785" data-belowelement="div-comment-1286" data-respondelement="respond" aria-label='Reply to Lukasz Erecinski'>Reply</a></div> </article>
</li>
</ol>
</li>
<li id="comment-1283" class="comment odd alt thread-odd thread-alt depth-1 parent">
<article id="div-comment-1283" class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt='' src='https://secure.gravatar.com/avatar/6c8ab87e59eac90ab68b9b3580c2b04c?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/6c8ab87e59eac90ab68b9b3580c2b04c?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' /> <b class="fn">derger</b> <span class="says">says:</span> </div>
<div class="comment-metadata">
<a href="https://www.pine64.org/2020/02/15/february-update-post-cny-and-fosdem-status-report/#comment-1283">
<time datetime="2020-02-16T19:32:47+00:00">
February 16, 2020 at 7:32 pm </time>
</a>
</div>
</footer>
<div class="comment-content">
<p>Wszyscy skupiają się na terminach, a ja zapytam o ceny. Czy ceny sprzetu beda sie zmniejszac (jak benzyna) czy rosnąć? Czy pineTab bedzie drozszy niż przewidywaliście?<br />
Czy nowe PinePhone bedzie tańszy?</p>
<p>Oczywiście jeszcze kwestia wirusów, które mogą przyjechać na pokładzie telefonu. Niestety przy temperaturach niskich nie ma okresu rozpadu (zniszczenia ) wirusa. Może żyć dowolna ilośc dni. Przy temperaturach pokojowych wytrzyma 9-12 dni na płaskich powierzchniach i pewnie grupo ponad miesiąc (nie testowano wiecej niż 42 dni) w porowatych jak styropian, gąbki itd. Zatem może się okazać, że najlepiej będzie NIE OTWIERAC paczki po otrzymaniu przez miesiąc. Co samo w sobie jest dziwne.</p>
</div>
<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://www.pine64.org/2020/02/15/february-update-post-cny-and-fosdem-status-report/?replytocom=1283#respond' data-commentid="1283" data-postid="1785" data-belowelement="div-comment-1283" data-respondelement="respond" aria-label='Reply to derger'>Reply</a></div> </article>
<ol class="children">
<li id="comment-1287" class="comment byuser comment-author-lukasz bypostauthor even depth-2">
<article id="div-comment-1287" class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt='' src='https://secure.gravatar.com/avatar/a1f3fab3b5cfa1427b77133541d179f3?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/a1f3fab3b5cfa1427b77133541d179f3?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' /> <b class="fn">Lukasz Erecinski</b> <span class="says">says:</span> </div>
<div class="comment-metadata">
<a href="https://www.pine64.org/2020/02/15/february-update-post-cny-and-fosdem-status-report/#comment-1287">
<time datetime="2020-02-16T22:28:37+00:00">
February 16, 2020 at 10:28 pm </time>
</a>
</div>
</footer>
<div class="comment-content">
<p>We are currently not expecting a price hike nor a price drop of any devices.</p>
</div>
<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://www.pine64.org/2020/02/15/february-update-post-cny-and-fosdem-status-report/?replytocom=1287#respond' data-commentid="1287" data-postid="1785" data-belowelement="div-comment-1287" data-respondelement="respond" aria-label='Reply to Lukasz Erecinski'>Reply</a></div> </article>
</li>
</ol>
</li>
</ol>
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/02/15/february-update-post-cny-and-fosdem-status-report/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.pine64.org/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="gdpr-terms-container">
<label>
<input type="checkbox" required name="gdpr_terms" id="gdpr_terms" value="1" />
I accept the <a href='https://www.pine64.org/pp/' target='_blank'>Privacy Policy</a> *
</label>
</p>
<p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='1785' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p></form> </div>
</div>
</main>
</div>
</div>
</div>
<footer id="colophon" class="site-footer" role="contentinfo">
<div id="top-footer" class="footer-widgets-wrapper footer_column_two np-clearfix">
<div class="mt-container">
<div class="footer-widgets-area np-clearfix">
<div class="np-footer-widget-wrapper np-column-wrapper np-clearfix">
<div class="np-footer-widget wow fadeInLeft" data-wow-duration="0.5s">
<section id="custom-twitter-feeds-widget-2" class="widget widget_custom-twitter-feeds-widget"><h4 class="widget-title">Follow us on Twitter</h4><div id="ctf" class="ctf ctf-type-usertimeline  ctf-styles" style="width: 100%;height: 370px;background-color: #ffffff;" data-ctfshortcode="{}" data-ctfintents="1" data-ctfneeded="1"><div class="ctf-tweets"><div class="ctf-item ctf-author-thepine64 ctf-new" id="1229166980919431169" style=""><div class="ctf-author-box"><div class="ctf-author-box-link" style=""><a href="https://twitter.com/thepine64" class="ctf-author-avatar" target="_blank" style=""><img src="https://pbs.twimg.com/profile_images/1212346148108849152/mOcPIVxg_normal.jpg" alt="thepine64" width="48" height="48"></a><a href="https://twitter.com/thepine64" target="_blank" class="ctf-author-name" style="">PINE64</a><a href="https://twitter.com/thepine64" class="ctf-author-screenname" target="_blank" style="">@thepine64</a><span class="ctf-screename-sep">&middot;</span><div class="ctf-tweet-meta"><a href="https://twitter.com/thepine64/status/1229166980919431169" class="ctf-tweet-date" target="_blank" style="">6h</a></div></div><div class="ctf-corner-logo" style=""><svg class="svg-inline--fa fa-twitter fa-w-16" aria-hidden="true" aria-label="twitter logo" data-fa-processed="" data-prefix="fab" data-icon="twitter" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512 512"><path fill="currentColor" d="M459.37 151.716c.325 4.548.325 9.097.325 13.645 0 138.72-105.583 298.558-298.558 298.558-59.452 0-114.68-17.219-161.137-47.106 8.447.974 16.568 1.299 25.34 1.299 49.055 0 94.213-16.568 130.274-44.832-46.132-.975-84.792-31.188-98.112-72.772 6.498.974 12.995 1.624 19.818 1.624 9.421 0 18.843-1.3 27.614-3.573-48.081-9.747-84.143-51.98-84.143-102.985v-1.299c13.969 7.797 30.214 12.67 47.431 13.319-28.264-18.843-46.781-51.005-46.781-87.391 0-19.492 5.197-37.36 14.294-52.954 51.655 63.675 129.3 105.258 216.365 109.807-1.624-7.797-2.599-15.918-2.599-24.04 0-57.828 46.782-104.934 104.934-104.934 30.213 0 57.502 12.67 76.67 33.137 23.715-4.548 46.456-13.32 66.599-25.34-7.798 24.366-24.366 44.833-46.132 57.827 21.117-2.273 41.584-8.122 60.426-16.243-14.292 20.791-32.161 39.308-52.628 54.253z"></path></svg></div></div><div class="ctf-tweet-content"><p class="ctf-tweet-text" style="">A look at @UBports #UbuntuTouch on the #PinePhone https://www.youtube.com/watch?v=JP-x3uNW0xI</div><div class="ctf-tweet-actions"><a href="https://twitter.com/intent/tweet?in_reply_to=1229166980919431169&related=thepine64" class="ctf-reply" target="_blank" style=""><svg class="svg-inline--fa fa-reply fa-w-16" aria-hidden="true" aria-label="reply" data-fa-processed="" data-prefix="fa" data-icon="reply" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512 512"><path fill="currentColor" d="M8.309 189.836L184.313 37.851C199.719 24.546 224 35.347 224 56.015v80.053c160.629 1.839 288 34.032 288 186.258 0 61.441-39.581 122.309-83.333 154.132-13.653 9.931-33.111-2.533-28.077-18.631 45.344-145.012-21.507-183.51-176.59-185.742V360c0 20.7-24.3 31.453-39.687 18.164l-176.004-152c-11.071-9.562-11.086-26.753 0-36.328z"></path></svg><span class="ctf-screenreader">Reply on Twitter 1229166980919431169</span></a><a href="https://twitter.com/intent/retweet?tweet_id=1229166980919431169&related=thepine64" class="ctf-retweet" target="_blank" style=""><svg class="svg-inline--fa fa-retweet fa-w-20" aria-hidden="true" aria-label="retweet" data-fa-processed="" data-prefix="fa" data-icon="retweet" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 640 512"><path fill="currentColor" d="M629.657 343.598L528.971 444.284c-9.373 9.372-24.568 9.372-33.941 0L394.343 343.598c-9.373-9.373-9.373-24.569 0-33.941l10.823-10.823c9.562-9.562 25.133-9.34 34.419.492L480 342.118V160H292.451a24.005 24.005 0 0 1-16.971-7.029l-16-16C244.361 121.851 255.069 96 276.451 96H520c13.255 0 24 10.745 24 24v222.118l40.416-42.792c9.285-9.831 24.856-10.054 34.419-.492l10.823 10.823c9.372 9.372 9.372 24.569-.001 33.941zm-265.138 15.431A23.999 23.999 0 0 0 347.548 352H160V169.881l40.416 42.792c9.286 9.831 24.856 10.054 34.419.491l10.822-10.822c9.373-9.373 9.373-24.569 0-33.941L144.971 67.716c-9.373-9.373-24.569-9.373-33.941 0L10.343 168.402c-9.373 9.373-9.373 24.569 0 33.941l10.822 10.822c9.562 9.562 25.133 9.34 34.419-.491L96 169.881V392c0 13.255 10.745 24 24 24h243.549c21.382 0 32.09-25.851 16.971-40.971l-16.001-16z"></path></svg><span class="ctf-screenreader">Retweet on Twitter 1229166980919431169</span><span class="ctf-action-count ctf-retweet-count">7</span></a><a href="https://twitter.com/intent/like?tweet_id=1229166980919431169&related=thepine64" class="ctf-like" target="_blank" style=""><svg class="svg-inline--fa fa-heart fa-w-18" aria-hidden="true" aria-label="like" data-fa-processed="" data-prefix="fa" data-icon="heart" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 576 512"><path fill="currentColor" d="M414.9 24C361.8 24 312 65.7 288 89.3 264 65.7 214.2 24 161.1 24 70.3 24 16 76.9 16 165.5c0 72.6 66.8 133.3 69.2 135.4l187 180.8c8.8 8.5 22.8 8.5 31.6 0l186.7-180.2c2.7-2.7 69.5-63.5 69.5-136C560 76.9 505.7 24 414.9 24z"></path></svg><span class="ctf-screenreader">Like on Twitter 1229166980919431169</span><span class="ctf-action-count ctf-favorite-count">27</span></a><a href="https://twitter.com/thepine64/status/1229166980919431169" class="ctf-twitterlink" style="" target="_blank">Twitter <span class="ctf-screenreader">1229166980919431169</span></a></div></div><div class="ctf-item ctf-author-thepine64 ctf-new ctf-retweet" id="1229148619418341377" style=""><div class="ctf-context"><a href="https://twitter.com/intent/user?screen_name=thepine64" target="_blank" class="ctf-retweet-icon"><svg class="svg-inline--fa fa-retweet fa-w-20" aria-hidden="true" aria-label="retweet" data-fa-processed="" data-prefix="fa" data-icon="retweet" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 640 512"><path fill="currentColor" d="M629.657 343.598L528.971 444.284c-9.373 9.372-24.568 9.372-33.941 0L394.343 343.598c-9.373-9.373-9.373-24.569 0-33.941l10.823-10.823c9.562-9.562 25.133-9.34 34.419.492L480 342.118V160H292.451a24.005 24.005 0 0 1-16.971-7.029l-16-16C244.361 121.851 255.069 96 276.451 96H520c13.255 0 24 10.745 24 24v222.118l40.416-42.792c9.285-9.831 24.856-10.054 34.419-.492l10.823 10.823c9.372 9.372 9.372 24.569-.001 33.941zm-265.138 15.431A23.999 23.999 0 0 0 347.548 352H160V169.881l40.416 42.792c9.286 9.831 24.856 10.054 34.419.491l10.822-10.822c9.373-9.373 9.373-24.569 0-33.941L144.971 67.716c-9.373-9.373-24.569-9.373-33.941 0L10.343 168.402c-9.373 9.373-9.373 24.569 0 33.941l10.822 10.822c9.562 9.562 25.133 9.34 34.419-.491L96 169.881V392c0 13.255 10.745 24 24 24h243.549c21.382 0 32.09-25.851 16.971-40.971l-16.001-16z"></path></svg><span class="ctf-screenreader">Retweet on Twitter</span></a><a href="https://twitter.com/thepine64" target="_blank" class="ctf-retweet-text" style="">PINE64 Retweeted</a></div><div class="ctf-author-box"><div class="ctf-author-box-link" style=""><a href="https://twitter.com/RealDanct12" class="ctf-author-avatar" target="_blank" style=""><img src="https://pbs.twimg.com/profile_images/1226387888922746882/16sEFxvT_normal.jpg" alt="RealDanct12" width="48" height="48"></a><a href="https://twitter.com/RealDanct12" target="_blank" class="ctf-author-name" style="">Danct12</a><a href="https://twitter.com/RealDanct12" class="ctf-author-screenname" target="_blank" style="">@RealDanct12</a><span class="ctf-screename-sep">&middot;</span><div class="ctf-tweet-meta"><a href="https://twitter.com/RealDanct12/status/1229148258355666944" class="ctf-tweet-date" target="_blank" style="">8h</a></div></div><div class="ctf-corner-logo" style=""><svg class="svg-inline--fa fa-twitter fa-w-16" aria-hidden="true" aria-label="twitter logo" data-fa-processed="" data-prefix="fab" data-icon="twitter" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512 512"><path fill="currentColor" d="M459.37 151.716c.325 4.548.325 9.097.325 13.645 0 138.72-105.583 298.558-298.558 298.558-59.452 0-114.68-17.219-161.137-47.106 8.447.974 16.568 1.299 25.34 1.299 49.055 0 94.213-16.568 130.274-44.832-46.132-.975-84.792-31.188-98.112-72.772 6.498.974 12.995 1.624 19.818 1.624 9.421 0 18.843-1.3 27.614-3.573-48.081-9.747-84.143-51.98-84.143-102.985v-1.299c13.969 7.797 30.214 12.67 47.431 13.319-28.264-18.843-46.781-51.005-46.781-87.391 0-19.492 5.197-37.36 14.294-52.954 51.655 63.675 129.3 105.258 216.365 109.807-1.624-7.797-2.599-15.918-2.599-24.04 0-57.828 46.782-104.934 104.934-104.934 30.213 0 57.502 12.67 76.67 33.137 23.715-4.548 46.456-13.32 66.599-25.34-7.798 24.366-24.366 44.833-46.132 57.827 21.117-2.273 41.584-8.122 60.426-16.243-14.292 20.791-32.161 39.308-52.628 54.253z"></path></svg></div></div><div class="ctf-tweet-content"><p class="ctf-tweet-text" style="">Updated to kernel 5.5, the #PinePhone needs a little bit kernel config change, but at the end the results are great! </p><a href="https://twitter.com/RealDanct12/status/1229148258355666944" target="_blank" class="ctf-tweet-text-media-wrap ctf-multi-media-icon">2<svg aria-hidden="true" aria-label="images in tweet" focusable="false" data-prefix="far" data-icon="image" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512 512" class="svg-inline--fa fa-image fa-w-16 fa-9x ctf-tweet-text-media"><path fill="currentColor" d="M464 64H48C21.49 64 0 85.49 0 112v288c0 26.51 21.49 48 48 48h416c26.51 0 48-21.49 48-48V112c0-26.51-21.49-48-48-48zm-6 336H54a6 6 0 0 1-6-6V118a6 6 0 0 1 6-6h404a6 6 0 0 1 6 6v276a6 6 0 0 1-6 6zM128 152c-22.091 0-40 17.909-40 40s17.909 40 40 40 40-17.909 40-40-17.909-40-40-40zM96 352h320v-80l-87.515-87.515c-4.686-4.686-12.284-4.686-16.971 0L192 304l-39.515-39.515c-4.686-4.686-12.284-4.686-16.971 0L96 304v48z" class=""></path></svg></a></div><div class="ctf-tweet-actions"><a href="https://twitter.com/intent/tweet?in_reply_to=1229148258355666944&related=RealDanct12" class="ctf-reply" target="_blank" style=""><svg class="svg-inline--fa fa-reply fa-w-16" aria-hidden="true" aria-label="reply" data-fa-processed="" data-prefix="fa" data-icon="reply" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512 512"><path fill="currentColor" d="M8.309 189.836L184.313 37.851C199.719 24.546 224 35.347 224 56.015v80.053c160.629 1.839 288 34.032 288 186.258 0 61.441-39.581 122.309-83.333 154.132-13.653 9.931-33.111-2.533-28.077-18.631 45.344-145.012-21.507-183.51-176.59-185.742V360c0 20.7-24.3 31.453-39.687 18.164l-176.004-152c-11.071-9.562-11.086-26.753 0-36.328z"></path></svg><span class="ctf-screenreader">Reply on Twitter 1229148258355666944</span></a><a href="https://twitter.com/intent/retweet?tweet_id=1229148258355666944&related=RealDanct12" class="ctf-retweet" target="_blank" style=""><svg class="svg-inline--fa fa-retweet fa-w-20" aria-hidden="true" aria-label="retweet" data-fa-processed="" data-prefix="fa" data-icon="retweet" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 640 512"><path fill="currentColor" d="M629.657 343.598L528.971 444.284c-9.373 9.372-24.568 9.372-33.941 0L394.343 343.598c-9.373-9.373-9.373-24.569 0-33.941l10.823-10.823c9.562-9.562 25.133-9.34 34.419.492L480 342.118V160H292.451a24.005 24.005 0 0 1-16.971-7.029l-16-16C244.361 121.851 255.069 96 276.451 96H520c13.255 0 24 10.745 24 24v222.118l40.416-42.792c9.285-9.831 24.856-10.054 34.419-.492l10.823 10.823c9.372 9.372 9.372 24.569-.001 33.941zm-265.138 15.431A23.999 23.999 0 0 0 347.548 352H160V169.881l40.416 42.792c9.286 9.831 24.856 10.054 34.419.491l10.822-10.822c9.373-9.373 9.373-24.569 0-33.941L144.971 67.716c-9.373-9.373-24.569-9.373-33.941 0L10.343 168.402c-9.373 9.373-9.373 24.569 0 33.941l10.822 10.822c9.562 9.562 25.133 9.34 34.419-.491L96 169.881V392c0 13.255 10.745 24 24 24h243.549c21.382 0 32.09-25.851 16.971-40.971l-16.001-16z"></path></svg><span class="ctf-screenreader">Retweet on Twitter 1229148258355666944</span><span class="ctf-action-count ctf-retweet-count">7</span></a><a href="https://twitter.com/intent/like?tweet_id=1229148258355666944&related=RealDanct12" class="ctf-like" target="_blank" style=""><svg class="svg-inline--fa fa-heart fa-w-18" aria-hidden="true" aria-label="like" data-fa-processed="" data-prefix="fa" data-icon="heart" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 576 512"><path fill="currentColor" d="M414.9 24C361.8 24 312 65.7 288 89.3 264 65.7 214.2 24 161.1 24 70.3 24 16 76.9 16 165.5c0 72.6 66.8 133.3 69.2 135.4l187 180.8c8.8 8.5 22.8 8.5 31.6 0l186.7-180.2c2.7-2.7 69.5-63.5 69.5-136C560 76.9 505.7 24 414.9 24z"></path></svg><span class="ctf-screenreader">Like on Twitter 1229148258355666944</span><span class="ctf-action-count ctf-favorite-count">29</span></a><a href="https://twitter.com/RealDanct12/status/1229148258355666944" class="ctf-twitterlink" style="" target="_blank">Twitter <span class="ctf-screenreader">1229148258355666944</span></a></div></div><div class="ctf-item ctf-author-thepine64 ctf-new ctf-retweet" id="1229056435444645888" style=""><div class="ctf-context"><a href="https://twitter.com/intent/user?screen_name=thepine64" target="_blank" class="ctf-retweet-icon"><svg class="svg-inline--fa fa-retweet fa-w-20" aria-hidden="true" aria-label="retweet" data-fa-processed="" data-prefix="fa" data-icon="retweet" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 640 512"><path fill="currentColor" d="M629.657 343.598L528.971 444.284c-9.373 9.372-24.568 9.372-33.941 0L394.343 343.598c-9.373-9.373-9.373-24.569 0-33.941l10.823-10.823c9.562-9.562 25.133-9.34 34.419.492L480 342.118V160H292.451a24.005 24.005 0 0 1-16.971-7.029l-16-16C244.361 121.851 255.069 96 276.451 96H520c13.255 0 24 10.745 24 24v222.118l40.416-42.792c9.285-9.831 24.856-10.054 34.419-.492l10.823 10.823c9.372 9.372 9.372 24.569-.001 33.941zm-265.138 15.431A23.999 23.999 0 0 0 347.548 352H160V169.881l40.416 42.792c9.286 9.831 24.856 10.054 34.419.491l10.822-10.822c9.373-9.373 9.373-24.569 0-33.941L144.971 67.716c-9.373-9.373-24.569-9.373-33.941 0L10.343 168.402c-9.373 9.373-9.373 24.569 0 33.941l10.822 10.822c9.562 9.562 25.133 9.34 34.419-.491L96 169.881V392c0 13.255 10.745 24 24 24h243.549c21.382 0 32.09-25.851 16.971-40.971l-16.001-16z"></path></svg><span class="ctf-screenreader">Retweet on Twitter</span></a><a href="https://twitter.com/thepine64" target="_blank" class="ctf-retweet-text" style="">PINE64 Retweeted</a></div><div class="ctf-author-box"><div class="ctf-author-box-link" style=""><a href="https://twitter.com/codingfield" class="ctf-author-avatar" target="_blank" style=""><img src="https://pbs.twimg.com/profile_images/733013850430263297/GzOQX1bA_normal.jpg" alt="codingfield" width="48" height="48"></a><a href="https://twitter.com/codingfield" target="_blank" class="ctf-author-name" style="">JF</a><a href="https://twitter.com/codingfield" class="ctf-author-screenname" target="_blank" style="">@codingfield</a><span class="ctf-screename-sep">&middot;</span><div class="ctf-tweet-meta"><a href="https://twitter.com/codingfield/status/1229054721031385088" class="ctf-tweet-date" target="_blank" style="">14h</a></div></div><div class="ctf-corner-logo" style=""><svg class="svg-inline--fa fa-twitter fa-w-16" aria-hidden="true" aria-label="twitter logo" data-fa-processed="" data-prefix="fab" data-icon="twitter" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512 512"><path fill="currentColor" d="M459.37 151.716c.325 4.548.325 9.097.325 13.645 0 138.72-105.583 298.558-298.558 298.558-59.452 0-114.68-17.219-161.137-47.106 8.447.974 16.568 1.299 25.34 1.299 49.055 0 94.213-16.568 130.274-44.832-46.132-.975-84.792-31.188-98.112-72.772 6.498.974 12.995 1.624 19.818 1.624 9.421 0 18.843-1.3 27.614-3.573-48.081-9.747-84.143-51.98-84.143-102.985v-1.299c13.969 7.797 30.214 12.67 47.431 13.319-28.264-18.843-46.781-51.005-46.781-87.391 0-19.492 5.197-37.36 14.294-52.954 51.655 63.675 129.3 105.258 216.365 109.807-1.624-7.797-2.599-15.918-2.599-24.04 0-57.828 46.782-104.934 104.934-104.934 30.213 0 57.502 12.67 76.67 33.137 23.715-4.548 46.456-13.32 66.599-25.34-7.798 24.366-24.366 44.833-46.132 57.827 21.117-2.273 41.584-8.122 60.426-16.243-14.292 20.791-32.161 39.308-52.628 54.253z"></path></svg></div></div><div class="ctf-tweet-content"><p class="ctf-tweet-text" style="">First integration of #littlevgl in my #pinetime firmware, with basic user interaction.<br />
@thepine64 </p><a href="https://twitter.com/codingfield/status/1229054721031385088" target="_blank" class="ctf-tweet-text-media-wrap"><svg aria-hidden="true" aria-label="video in tweet" focusable="false" data-prefix="far" data-icon="file-video" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 384 512" class="svg-inline--fa fa-file-video fa-w-12 fa-9x ctf-tweet-text-media"><path fill="currentColor" d="M369.941 97.941l-83.882-83.882A48 48 0 0 0 252.118 0H48C21.49 0 0 21.49 0 48v416c0 26.51 21.49 48 48 48h288c26.51 0 48-21.49 48-48V131.882a48 48 0 0 0-14.059-33.941zM332.118 128H256V51.882L332.118 128zM48 464V48h160v104c0 13.255 10.745 24 24 24h104v288H48zm228.687-211.303L224 305.374V268c0-11.046-8.954-20-20-20H100c-11.046 0-20 8.954-20 20v104c0 11.046 8.954 20 20 20h104c11.046 0 20-8.954 20-20v-37.374l52.687 52.674C286.704 397.318 304 390.28 304 375.986V264.011c0-14.311-17.309-21.319-27.313-11.314z" class=""></path></svg></a></div><div class="ctf-tweet-actions"><a href="https://twitter.com/intent/tweet?in_reply_to=1229054721031385088&related=codingfield" class="ctf-reply" target="_blank" style=""><svg class="svg-inline--fa fa-reply fa-w-16" aria-hidden="true" aria-label="reply" data-fa-processed="" data-prefix="fa" data-icon="reply" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512 512"><path fill="currentColor" d="M8.309 189.836L184.313 37.851C199.719 24.546 224 35.347 224 56.015v80.053c160.629 1.839 288 34.032 288 186.258 0 61.441-39.581 122.309-83.333 154.132-13.653 9.931-33.111-2.533-28.077-18.631 45.344-145.012-21.507-183.51-176.59-185.742V360c0 20.7-24.3 31.453-39.687 18.164l-176.004-152c-11.071-9.562-11.086-26.753 0-36.328z"></path></svg><span class="ctf-screenreader">Reply on Twitter 1229054721031385088</span></a><a href="https://twitter.com/intent/retweet?tweet_id=1229054721031385088&related=codingfield" class="ctf-retweet" target="_blank" style=""><svg class="svg-inline--fa fa-retweet fa-w-20" aria-hidden="true" aria-label="retweet" data-fa-processed="" data-prefix="fa" data-icon="retweet" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 640 512"><path fill="currentColor" d="M629.657 343.598L528.971 444.284c-9.373 9.372-24.568 9.372-33.941 0L394.343 343.598c-9.373-9.373-9.373-24.569 0-33.941l10.823-10.823c9.562-9.562 25.133-9.34 34.419.492L480 342.118V160H292.451a24.005 24.005 0 0 1-16.971-7.029l-16-16C244.361 121.851 255.069 96 276.451 96H520c13.255 0 24 10.745 24 24v222.118l40.416-42.792c9.285-9.831 24.856-10.054 34.419-.492l10.823 10.823c9.372 9.372 9.372 24.569-.001 33.941zm-265.138 15.431A23.999 23.999 0 0 0 347.548 352H160V169.881l40.416 42.792c9.286 9.831 24.856 10.054 34.419.491l10.822-10.822c9.373-9.373 9.373-24.569 0-33.941L144.971 67.716c-9.373-9.373-24.569-9.373-33.941 0L10.343 168.402c-9.373 9.373-9.373 24.569 0 33.941l10.822 10.822c9.562 9.562 25.133 9.34 34.419-.491L96 169.881V392c0 13.255 10.745 24 24 24h243.549c21.382 0 32.09-25.851 16.971-40.971l-16.001-16z"></path></svg><span class="ctf-screenreader">Retweet on Twitter 1229054721031385088</span><span class="ctf-action-count ctf-retweet-count">11</span></a><a href="https://twitter.com/intent/like?tweet_id=1229054721031385088&related=codingfield" class="ctf-like" target="_blank" style=""><svg class="svg-inline--fa fa-heart fa-w-18" aria-hidden="true" aria-label="like" data-fa-processed="" data-prefix="fa" data-icon="heart" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 576 512"><path fill="currentColor" d="M414.9 24C361.8 24 312 65.7 288 89.3 264 65.7 214.2 24 161.1 24 70.3 24 16 76.9 16 165.5c0 72.6 66.8 133.3 69.2 135.4l187 180.8c8.8 8.5 22.8 8.5 31.6 0l186.7-180.2c2.7-2.7 69.5-63.5 69.5-136C560 76.9 505.7 24 414.9 24z"></path></svg><span class="ctf-screenreader">Like on Twitter 1229054721031385088</span><span class="ctf-action-count ctf-favorite-count">61</span></a><a href="https://twitter.com/codingfield/status/1229054721031385088" class="ctf-twitterlink" style="" target="_blank">Twitter <span class="ctf-screenreader">1229054721031385088</span></a></div></div><div class="ctf-item ctf-author-thepine64 ctf-new ctf-retweet" id="1229002426843353089" style=""><div class="ctf-context"><a href="https://twitter.com/intent/user?screen_name=thepine64" target="_blank" class="ctf-retweet-icon"><svg class="svg-inline--fa fa-retweet fa-w-20" aria-hidden="true" aria-label="retweet" data-fa-processed="" data-prefix="fa" data-icon="retweet" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 640 512"><path fill="currentColor" d="M629.657 343.598L528.971 444.284c-9.373 9.372-24.568 9.372-33.941 0L394.343 343.598c-9.373-9.373-9.373-24.569 0-33.941l10.823-10.823c9.562-9.562 25.133-9.34 34.419.492L480 342.118V160H292.451a24.005 24.005 0 0 1-16.971-7.029l-16-16C244.361 121.851 255.069 96 276.451 96H520c13.255 0 24 10.745 24 24v222.118l40.416-42.792c9.285-9.831 24.856-10.054 34.419-.492l10.823 10.823c9.372 9.372 9.372 24.569-.001 33.941zm-265.138 15.431A23.999 23.999 0 0 0 347.548 352H160V169.881l40.416 42.792c9.286 9.831 24.856 10.054 34.419.491l10.822-10.822c9.373-9.373 9.373-24.569 0-33.941L144.971 67.716c-9.373-9.373-24.569-9.373-33.941 0L10.343 168.402c-9.373 9.373-9.373 24.569 0 33.941l10.822 10.822c9.562 9.562 25.133 9.34 34.419-.491L96 169.881V392c0 13.255 10.745 24 24 24h243.549c21.382 0 32.09-25.851 16.971-40.971l-16.001-16z"></path></svg><span class="ctf-screenreader">Retweet on Twitter</span></a><a href="https://twitter.com/thepine64" target="_blank" class="ctf-retweet-text" style="">PINE64 Retweeted</a></div><div class="ctf-author-box"><div class="ctf-author-box-link" style=""><a href="https://twitter.com/Zero_ChaosX" class="ctf-author-avatar" target="_blank" style=""><img src="https://pbs.twimg.com/profile_images/1572631478/North_20Westside-20110426-00002_normal.jpg" alt="Zero_ChaosX" width="48" height="48"></a><a href="https://twitter.com/Zero_ChaosX" target="_blank" class="ctf-author-name" style="">Zero_Chaos</a><a href="https://twitter.com/Zero_ChaosX" class="ctf-author-screenname" target="_blank" style="">@Zero_ChaosX</a><span class="ctf-screename-sep">&middot;</span><div class="ctf-tweet-meta"><a href="https://twitter.com/Zero_ChaosX/status/1228838639389564928" class="ctf-tweet-date" target="_blank" style="">16 Feb</a></div></div><div class="ctf-corner-logo" style=""><svg class="svg-inline--fa fa-twitter fa-w-16" aria-hidden="true" aria-label="twitter logo" data-fa-processed="" data-prefix="fab" data-icon="twitter" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512 512"><path fill="currentColor" d="M459.37 151.716c.325 4.548.325 9.097.325 13.645 0 138.72-105.583 298.558-298.558 298.558-59.452 0-114.68-17.219-161.137-47.106 8.447.974 16.568 1.299 25.34 1.299 49.055 0 94.213-16.568 130.274-44.832-46.132-.975-84.792-31.188-98.112-72.772 6.498.974 12.995 1.624 19.818 1.624 9.421 0 18.843-1.3 27.614-3.573-48.081-9.747-84.143-51.98-84.143-102.985v-1.299c13.969 7.797 30.214 12.67 47.431 13.319-28.264-18.843-46.781-51.005-46.781-87.391 0-19.492 5.197-37.36 14.294-52.954 51.655 63.675 129.3 105.258 216.365 109.807-1.624-7.797-2.599-15.918-2.599-24.04 0-57.828 46.782-104.934 104.934-104.934 30.213 0 57.502 12.67 76.67 33.137 23.715-4.548 46.456-13.32 66.599-25.34-7.798 24.366-24.366 44.833-46.132 57.827 21.117-2.273 41.584-8.122 60.426-16.243-14.292 20.791-32.161 39.308-52.628 54.253z"></path></svg></div></div><div class="ctf-tweet-content"><p class="ctf-tweet-text" style="">Is this the first @thepine64 PinePhone running kismet? cc @KismetWireless @WiFi_Village </p><a href="https://twitter.com/Zero_ChaosX/status/1228838639389564928" target="_blank" class="ctf-tweet-text-media-wrap"><svg aria-hidden="true" aria-label="images in tweet" focusable="false" data-prefix="far" data-icon="image" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512 512" class="svg-inline--fa fa-image fa-w-16 fa-9x ctf-tweet-text-media"><path fill="currentColor" d="M464 64H48C21.49 64 0 85.49 0 112v288c0 26.51 21.49 48 48 48h416c26.51 0 48-21.49 48-48V112c0-26.51-21.49-48-48-48zm-6 336H54a6 6 0 0 1-6-6V118a6 6 0 0 1 6-6h404a6 6 0 0 1 6 6v276a6 6 0 0 1-6 6zM128 152c-22.091 0-40 17.909-40 40s17.909 40 40 40 40-17.909 40-40-17.909-40-40-40zM96 352h320v-80l-87.515-87.515c-4.686-4.686-12.284-4.686-16.971 0L192 304l-39.515-39.515c-4.686-4.686-12.284-4.686-16.971 0L96 304v48z" class=""></path></svg></a></div><div class="ctf-tweet-actions"><a href="https://twitter.com/intent/tweet?in_reply_to=1228838639389564928&related=Zero_ChaosX" class="ctf-reply" target="_blank" style=""><svg class="svg-inline--fa fa-reply fa-w-16" aria-hidden="true" aria-label="reply" data-fa-processed="" data-prefix="fa" data-icon="reply" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512 512"><path fill="currentColor" d="M8.309 189.836L184.313 37.851C199.719 24.546 224 35.347 224 56.015v80.053c160.629 1.839 288 34.032 288 186.258 0 61.441-39.581 122.309-83.333 154.132-13.653 9.931-33.111-2.533-28.077-18.631 45.344-145.012-21.507-183.51-176.59-185.742V360c0 20.7-24.3 31.453-39.687 18.164l-176.004-152c-11.071-9.562-11.086-26.753 0-36.328z"></path></svg><span class="ctf-screenreader">Reply on Twitter 1228838639389564928</span></a><a href="https://twitter.com/intent/retweet?tweet_id=1228838639389564928&related=Zero_ChaosX" class="ctf-retweet" target="_blank" style=""><svg class="svg-inline--fa fa-retweet fa-w-20" aria-hidden="true" aria-label="retweet" data-fa-processed="" data-prefix="fa" data-icon="retweet" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 640 512"><path fill="currentColor" d="M629.657 343.598L528.971 444.284c-9.373 9.372-24.568 9.372-33.941 0L394.343 343.598c-9.373-9.373-9.373-24.569 0-33.941l10.823-10.823c9.562-9.562 25.133-9.34 34.419.492L480 342.118V160H292.451a24.005 24.005 0 0 1-16.971-7.029l-16-16C244.361 121.851 255.069 96 276.451 96H520c13.255 0 24 10.745 24 24v222.118l40.416-42.792c9.285-9.831 24.856-10.054 34.419-.492l10.823 10.823c9.372 9.372 9.372 24.569-.001 33.941zm-265.138 15.431A23.999 23.999 0 0 0 347.548 352H160V169.881l40.416 42.792c9.286 9.831 24.856 10.054 34.419.491l10.822-10.822c9.373-9.373 9.373-24.569 0-33.941L144.971 67.716c-9.373-9.373-24.569-9.373-33.941 0L10.343 168.402c-9.373 9.373-9.373 24.569 0 33.941l10.822 10.822c9.562 9.562 25.133 9.34 34.419-.491L96 169.881V392c0 13.255 10.745 24 24 24h243.549c21.382 0 32.09-25.851 16.971-40.971l-16.001-16z"></path></svg><span class="ctf-screenreader">Retweet on Twitter 1228838639389564928</span><span class="ctf-action-count ctf-retweet-count">16</span></a><a href="https://twitter.com/intent/like?tweet_id=1228838639389564928&related=Zero_ChaosX" class="ctf-like" target="_blank" style=""><svg class="svg-inline--fa fa-heart fa-w-18" aria-hidden="true" aria-label="like" data-fa-processed="" data-prefix="fa" data-icon="heart" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 576 512"><path fill="currentColor" d="M414.9 24C361.8 24 312 65.7 288 89.3 264 65.7 214.2 24 161.1 24 70.3 24 16 76.9 16 165.5c0 72.6 66.8 133.3 69.2 135.4l187 180.8c8.8 8.5 22.8 8.5 31.6 0l186.7-180.2c2.7-2.7 69.5-63.5 69.5-136C560 76.9 505.7 24 414.9 24z"></path></svg><span class="ctf-screenreader">Like on Twitter 1228838639389564928</span><span class="ctf-action-count ctf-favorite-count">81</span></a><a href="https://twitter.com/Zero_ChaosX/status/1228838639389564928" class="ctf-twitterlink" style="" target="_blank">Twitter <span class="ctf-screenreader">1228838639389564928</span></a></div></div></div><a href="javascript:void(0);" id="ctf-more" class="ctf-more" style=""><span>Load More...</span></a></div></section><section id="blog_subscription-3" class="widget widget_blog_subscription jetpack_subscription_widget"><h4 class="widget-title">Subscribe to the PINE64 Blog</h4>
<form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-3">
<p id="subscribe-email">
<label id="jetpack-subscribe-label" class="screen-reader-text" for="subscribe-field-blog_subscription-3">
 Email Address </label>
<input type="email" name="email" required="required" class="required" value="" id="subscribe-field-blog_subscription-3" placeholder="Email Address" />
</p>
<p id="subscribe-submit">
<input type="hidden" name="action" value="subscribe" />
<input type="hidden" name="source" value="https://www.pine64.org/2020/02/15/february-update-post-cny-and-fosdem-status-report/" />
<input type="hidden" name="sub-type" value="widget" />
<input type="hidden" name="redirect_fragment" value="blog_subscription-3" />
<button type="submit" name="jetpack_subscriptions_widget">
Subscribe </button>
</p>
</form>
</section><section id="rss_links-3" class="widget widget_rss_links"><h4 class="widget-title">BLOG RSS FEED</h4><p><a target="_self" href="https://www.pine64.org/feed/" title="Subscribe to Posts"><img src="https://www.pine64.org/wp-content/plugins/jetpack/images/rss/silver-large.png" alt="RSS Feed" /></a></p>
</section><section id="media_image-7" class="widget widget_media_image"><h4 class="widget-title">Hosts of the PINE64 cluster</h4><a href="https://www.bbxnet.sk/"><img width="214" height="45" src="https://www.pine64.org/wp-content/uploads/2019/11/BBXNETLogo2-1.png" class="image wp-image-1571  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" /></a></section> </div>
<div class="np-footer-widget wow fadeInLeft" data-woww-duration="1s">
<section id="news_portal_recent_posts-3" class="widget news_portal_recent_posts"> <div class="np-recent-posts-wrapper">
<h4 class="widget-title">Recent</h4><ul> <li>
<div class="np-single-post np-clearfix">
<div class="np-post-thumb">
<a href="https://www.pine64.org/2020/02/15/february-update-post-cny-and-fosdem-status-report/">
</a>
</div>
<div class="np-post-content">
<h3 class="np-post-title small-size"><a href="https://www.pine64.org/2020/02/15/february-update-post-cny-and-fosdem-status-report/">February Update: Post CNY and FOSDEM Status Report</a></h3>
<div class="np-post-meta"><span class="posted-on"><a href="https://www.pine64.org/2020/02/15/february-update-post-cny-and-fosdem-status-report/" rel="bookmark"><time class="entry-date published" datetime="2020-02-15T21:57:53+00:00">February 15, 2020</time><time class="updated" datetime="2020-02-15T23:31:59+00:00">February 15, 2020</time></a></span><span class="byline"><span class="author vcard"><a class="url fn n" href="https://www.pine64.org/author/lukasz/">Lukasz Erecinski</a></span></span></div>
</div>
</div>
</li>
<li>
<div class="np-single-post np-clearfix">
<div class="np-post-thumb">
<a href="https://www.pine64.org/2020/02/03/fosdem-2020-and-hardware-announcements/">
</a>
</div>
 <div class="np-post-content">
<h3 class="np-post-title small-size"><a href="https://www.pine64.org/2020/02/03/fosdem-2020-and-hardware-announcements/">FOSDEM 2020 and Hardware Announcements</a></h3>
<div class="np-post-meta"><span class="posted-on"><a href="https://www.pine64.org/2020/02/03/fosdem-2020-and-hardware-announcements/" rel="bookmark"><time class="entry-date published" datetime="2020-02-03T16:27:28+00:00">February 3, 2020</time><time class="updated" datetime="2020-02-04T00:07:08+00:00">February 4, 2020</time></a></span><span class="byline"><span class="author vcard"><a class="url fn n" href="https://www.pine64.org/author/lukasz/">Lukasz Erecinski</a></span></span></div>
</div>
</div>
</li>
<li>
<div class="np-single-post np-clearfix">
<div class="np-post-thumb">
<a href="https://www.pine64.org/2020/01/24/setting-the-record-straight-pinephone-misconceptions/">
</a>
</div>
<div class="np-post-content">
<h3 class="np-post-title small-size"><a href="https://www.pine64.org/2020/01/24/setting-the-record-straight-pinephone-misconceptions/">Setting the Record Straight: PinePhone Misconceptions</a></h3>
<div class="np-post-meta"><span class="posted-on"><a href="https://www.pine64.org/2020/01/24/setting-the-record-straight-pinephone-misconceptions/" rel="bookmark"><time class="entry-date published" datetime="2020-01-24T23:55:08+00:00">January 24, 2020</time><time class="updated" datetime="2020-01-25T02:22:39+00:00">January 25, 2020</time></a></span><span class="byline"><span class="author vcard"><a class="url fn n" href="https://www.pine64.org/author/lukasz/">Lukasz Erecinski</a></span></span></div>
</div>
</div>
</li>
<li>
<div class="np-single-post np-clearfix">
<div class="np-post-thumb">
<a href="https://www.pine64.org/2020/01/15/pinephones-start-shipping-all-you-want-to-know/">
</a>
</div>
<div class="np-post-content">
<h3 class="np-post-title small-size"><a href="https://www.pine64.org/2020/01/15/pinephones-start-shipping-all-you-want-to-know/">PinePhones Start Shipping &#8211; All You Need To Know</a></h3>
<div class="np-post-meta"><span class="posted-on"><a href="https://www.pine64.org/2020/01/15/pinephones-start-shipping-all-you-want-to-know/" rel="bookmark"><time class="entry-date published" datetime="2020-01-15T22:22:48+00:00">January 15, 2020</time><time class="updated" datetime="2020-01-16T17:37:30+00:00">January 16, 2020</time></a></span><span class="byline"><span class="author vcard"><a class="url fn n" href="https://www.pine64.org/author/lukasz/">Lukasz Erecinski</a></span></span></div>
</div>
</div>
</li>
<li>
<div class="np-single-post np-clearfix">
 <div class="np-post-thumb">
<a href="https://www.pine64.org/2019/12/05/december-update-thank-you-for-2019/">
</a>
</div>
<div class="np-post-content">
<h3 class="np-post-title small-size"><a href="https://www.pine64.org/2019/12/05/december-update-thank-you-for-2019/">December Update: Thank You For 2019!</a></h3>
<div class="np-post-meta"><span class="posted-on"><a href="https://www.pine64.org/2019/12/05/december-update-thank-you-for-2019/" rel="bookmark"><time class="entry-date published" datetime="2019-12-05T21:46:46+00:00">December 5, 2019</time><time class="updated" datetime="2019-12-06T14:26:40+00:00">December 6, 2019</time></a></span><span class="byline"><span class="author vcard"><a class="url fn n" href="https://www.pine64.org/author/lukasz/">Lukasz Erecinski</a></span></span></div>
</div>
</div>
</li>
</ul> </div>
</section><section id="archives-6" class="widget widget_archive"><h4 class="widget-title">Archives</h4> <ul>
<li><a href='https://www.pine64.org/2020/02/'>February 2020</a></li>
<li><a href='https://www.pine64.org/2020/01/'>January 2020</a></li>
<li><a href='https://www.pine64.org/2019/12/'>December 2019</a></li>
<li><a href='https://www.pine64.org/2019/11/'>November 2019</a></li>
<li><a href='https://www.pine64.org/2019/10/'>October 2019</a></li>
<li><a href='https://www.pine64.org/2019/09/'>September 2019</a></li>
<li><a href='https://www.pine64.org/2019/08/'>August 2019</a></li>
<li><a href='https://www.pine64.org/2019/07/'>July 2019</a></li>
<li><a href='https://www.pine64.org/2019/06/'>June 2019</a></li>
<li><a href='https://www.pine64.org/2019/05/'>May 2019</a></li>
<li><a href='https://www.pine64.org/2019/04/'>April 2019</a></li>
</ul>
</section> </div>
</div>
</div>
</div>
</div><div class="bottom-footer np-clearfix"><div class="mt-container"> <div class="site-info">
<span class="np-copyright-text">
Copyright PINE64 2019 </span>
<span class="sep"> | </span>
Theme: News Portal by <a href="https://mysterythemes.com/" rel="designer" target="_blank">Mystery Themes</a>. </div>
<nav id="footer-navigation" class="footer-navigation" role="navigation">
<div class="menu-footer-menu-container"><ul id="footer-menu" class="menu"><li id="menu-item-889" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-889"><a href="https://www.pine64.org/pp/">Privacy Policy</a></li>
</ul></div> </nav>
</div></div> </footer><div id="np-scrollup" class="animated arrow-hide"><i class="fa fa-chevron-up"></i></div></div>
<div style="display:none">
<div class="grofile-hash-map-0a8a165c24ed29b3a196e9dab465794e">
</div>
<div class="grofile-hash-map-a1f3fab3b5cfa1427b77133541d179f3">
</div>
<div class="grofile-hash-map-8fa0fd1d4ad35da668a1b51615bf04f6">
</div>
<div class="grofile-hash-map-f65b868cd03e1285a4c46f9deb8fef63">
</div>
<div class="grofile-hash-map-f4cb4cdf6b42adc2e8c6e68443fd8a94">
</div>
<div class="grofile-hash-map-83f9ecc295d6f9a1b5f0b6791f5a62ce">
</div>
<div class="grofile-hash-map-3858032bada534b00e43a27317e01eb7">
</div>
<div class="grofile-hash-map-6c8ab87e59eac90ab68b9b3580c2b04c">
</div>
</div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type='text/javascript'>
/* <![CDATA[ */
var gdpr_policy_page = {"gdpr_url":"https:\/\/www.pine64.org\/pp\/","gdpr_message":"This website uses cookies to ensure you get the best experience on our website.","gdpr_dismiss":"Decline","gdpr_allow":"Accept","gdpr_header":"","gdpr_link":"Learn more","gdpr_popup_position":"bottom-left","gdpr_popup_type":"opt-out","gdpr_popup_static":"","gdpr_popup_background":"#efefef","gdpr_popup_text":"#404040","gdpr_button_background":"transparent","gdpr_button_text":"#8ec760","gdpr_button_border":"#8ec760","gdpr_popup_theme":"classic","gdpr_hide":"1","gdpr_popup":"1","policy":"Cookie Policy","ajaxurl":"https:\/\/www.pine64.org\/wp-admin\/admin-ajax.php","gdpr_link_target":"_blank"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.pine64.org/wp-content/plugins/gdpr-framework/assets/cookieconsent.js'></script>
<script type='text/javascript' src='https://www.pine64.org/wp-content/plugins/mystickymenu/js/detectmobilebrowser.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var option = {"mystickyClass":".menu-main-menu-container","activationHeight":"0","disableWidth":"768","disableLargeWidth":"0","adminBar":"false","device_desktop":"1","device_mobile":"1","mystickyTransition":"fade","mysticky_disable_down":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.pine64.org/wp-content/plugins/mystickymenu/js/mystickymenu.min.js'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.2/modules/wpgroho.js'></script>
<script type='text/javascript' src='https://www.pine64.org/wp-content/themes/news-portal/assets/js/navigation.js'></script>
<script type='text/javascript' src='https://www.pine64.org/wp-content/themes/news-portal/assets/js/skip-link-focus-fix.js'></script>
<script type='text/javascript' src='https://www.pine64.org/wp-content/themes/news-portal/assets/library/lightslider/js/lightslider.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/ui/core.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/ui/widget.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/ui/tabs.min.js'></script>
<script type='text/javascript' src='https://www.pine64.org/wp-content/themes/news-portal/assets/js/np-custom-scripts.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript' src='https://www.pine64.org/wp-content/plugins/weather-effect/assets/js/christmas-snow/christmas-snow.js'></script>
<script type='text/javascript' src='https://www.pine64.org/wp-content/plugins/weather-effect/assets/js/snow-falling/snow-falling.js'></script>
<script type='text/javascript' src='https://www.pine64.org/wp-content/plugins/weather-effect/assets/js/snowfall-master/snowfall-master.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ctf = {"ajax_url":"https:\/\/www.pine64.org\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.pine64.org/wp-content/plugins/custom-twitter-feeds/js/ctf-scripts.min.js'></script>
<script type='text/javascript' src='https://www.pine64.org/wp-content/plugins/elementor/assets/js/frontend-modules.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/ui/position.min.js'></script>
<script type='text/javascript' src='https://www.pine64.org/wp-content/plugins/elementor/assets/lib/dialog/dialog.min.js'></script>
<script type='text/javascript' src='https://www.pine64.org/wp-content/plugins/elementor/assets/lib/waypoints/waypoints.min.js'></script>
<script type='text/javascript' src='https://www.pine64.org/wp-content/plugins/elementor/assets/lib/swiper/swiper.min.js'></script>
<script type='text/javascript' src='https://www.pine64.org/wp-content/plugins/elementor/assets/lib/share-link/share-link.min.js'></script>
<script type='text/javascript'>
var elementorFrontendConfig = {"environmentMode":{"edit":false,"wpPreview":false},"i18n":{"shareOnFacebook":"Share on Facebook","shareOnTwitter":"Share on Twitter","pinIt":"Pin it","downloadImage":"Download image"},"is_rtl":false,"breakpoints":{"xs":0,"sm":480,"md":768,"lg":1025,"xl":1440,"xxl":1600},"version":"2.9.2","urls":{"assets":"https:\/\/www.pine64.org\/wp-content\/plugins\/elementor\/assets\/"},"settings":{"page":[],"general":{"elementor_global_image_lightbox":"yes","elementor_lightbox_enable_counter":"yes","elementor_lightbox_enable_fullscreen":"yes","elementor_lightbox_enable_zoom":"yes","elementor_lightbox_enable_share":"yes","elementor_lightbox_title_src":"title","elementor_lightbox_description_src":"description"},"editorPreferences":[]},"post":{"id":1785,"title":"February Update: Post CNY and FOSDEM Status Report | PINE64","excerpt":"","featuredImage":false}};
</script>
<script type='text/javascript' src='https://www.pine64.org/wp-content/plugins/elementor/assets/js/frontend.min.js'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202008.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.2',blog:'161758425',post:'1785',tz:'0',srv:'www.pine64.org'} ]);
	_stq.push([ 'clickTrackerInit', '161758425', '1785' ]);
</script>
<script type="text/javascript">
        jQuery(document).ready(function ($) {
            //$( document ).ajaxStart(function() {
            //});

			
            for (var i = 0; i < document.forms.length; ++i) {
                var form = document.forms[i];
				if ($(form).attr("method") != "get") { $(form).append('<input type="hidden" name="G-ScXM" value="P7FK*o" />'); }
if ($(form).attr("method") != "get") { $(form).append('<input type="hidden" name="KnpQhXvmPSYLIe" value="A@XsO_1REQvuDJ" />'); }
if ($(form).attr("method") != "get") { $(form).append('<input type="hidden" name="huxItJo_" value="LV5Xro_K" />'); }
if ($(form).attr("method") != "get") { $(form).append('<input type="hidden" name="nZvwGNKYBA" value="nuprOXMiRK" />'); }
            }

			
            $(document).on('submit', 'form', function () {
				if ($(this).attr("method") != "get") { $(this).append('<input type="hidden" name="G-ScXM" value="P7FK*o" />'); }
if ($(this).attr("method") != "get") { $(this).append('<input type="hidden" name="KnpQhXvmPSYLIe" value="A@XsO_1REQvuDJ" />'); }
if ($(this).attr("method") != "get") { $(this).append('<input type="hidden" name="huxItJo_" value="LV5Xro_K" />'); }
if ($(this).attr("method") != "get") { $(this).append('<input type="hidden" name="nZvwGNKYBA" value="nuprOXMiRK" />'); }
                return true;
            });

			
            jQuery.ajaxSetup({
                beforeSend: function (e, data) {

                    //console.log(Object.getOwnPropertyNames(data).sort());
                    //console.log(data.type);

                    if (data.type !== 'POST') return;

                    if (typeof data.data === 'object' && data.data !== null) {
						data.data.append("G-ScXM", "P7FK*o");
data.data.append("KnpQhXvmPSYLIe", "A@XsO_1REQvuDJ");
data.data.append("huxItJo_", "LV5Xro_K");
data.data.append("nZvwGNKYBA", "nuprOXMiRK");
                    }
                    else {
                        data.data =  data.data + '&G-ScXM=P7FK*o&KnpQhXvmPSYLIe=A@XsO_1REQvuDJ&huxItJo_=LV5Xro_K&nZvwGNKYBA=nuprOXMiRK';
                    }
                }
            });

        });
	</script>
</body>
</html>